cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
opticshrew
Resolver II
Resolver II

data source credentials can't update online

Hi all,

 

I've created a report from a CRM (ODATA) dataset which I connected to using OAuth2 which succesfully connected. From here I could then create my tables and graphs and succesfully publish this to Pbi Online. I was then able to schedule a refresh which is keeping my data in this report up to date. Excellent!!

 

However, I have created a new seperate report. I am connecting to the same data set using my OAuth2 credentials and am succesfully connecting. I can still create tables and graphs succesfully and I can still publish to Pbi Online. The issue is I am seeing an alert with the data refresh that says my credentials are invalid. When changing the credentials (As Suggested) it shows an error stating it is unable to update the date source credentials.

 

I have attached the below alerts:

 

Your data source can't be refreshed because the credentials are invalid. Please update your credentials and try again.Your data source can't be queried because the credentials are not provided. Please provide your credentials and try again.Hide details

Activity ID:04efc08e-608a-4925-9959-b2f8ecd92207
Request ID:1bea3487-1015-2664-f861-c7897eea26ed
Status code:200
Time:Wed Nov 30 2016 10:20:07 GMT+0000 (GMT Standard Time)
Version:13.0.1700.679

 

 

I've also tried publishing the report to different workspaces however with no avail. It's also worth noting that I have a personal gateway on my machine that shows with the initial report however not with the second report. To my knowledge I shouldn't need the gateway as it is an online dataset.

1 ACCEPTED SOLUTION
opticshrew
Resolver II
Resolver II

Hi all,

 

Since updating the client my credentials seem to have been wiped from the report preventing a refresh. I have since updated these creds and republished the report. I am no longer experiencing the issue following this.

 

Thanks,

J

View solution in original post

3 REPLIES 3
opticshrew
Resolver II
Resolver II

Hi all,

 

Since updating the client my credentials seem to have been wiped from the report preventing a refresh. I have since updated these creds and republished the report. I am no longer experiencing the issue following this.

 

Thanks,

J

Hi @opticshrew

I have created a report and installed personal gateway on my system. I am extracting data from SQL Server, its working fine when I refresh in Power BI Desktop version but not in Power BI Online. I am getting error in my data credentials, which is the same credentials I use on SQL Server. Do I need to update it anywhere else as well. Can you elaborate what changes you made.
"Your data source cannot be refreshed because the credentials are invalid"
PFA screenshot of my error.

Activity ID:3a84f4f9-6adc-64f0-8fff-8891d069f84e
Request ID:bb69b3e7-44fa-8609-3bd5-62462fc4dc72
Status code:400
Time:Tue Jul 11 2017 16:23:50 GMT-0400 (Eastern Standard Time)
Version:13.0.1828.219
Cluster URI:https://wabi-us-north-central-redirect.analysis.windows.net


Any help is appreciated, thank in advance.


Regards,
Sahil

Hi @sahilhira162

 

You can do a couple of different things:

1- Update your client, there has been a recent update to Power Bi desktop

2- Open File > Options and Settings > Data Source Settings (Then update your credentials)

3- I've also found it helps to refresh the preview in the query editor (Sometimes there are error triangles)

 

Hope this helps,

J

 

Helpful resources

Announcements
Power BI Show Ep 4 Post Show Carousel.jpg

The Power BI Community Show

Shabnam Watson demos Incremental refresh & Hybrid Tables and Leila Etaati demos Charticulator.

PBI April Release 2022 768x460.png

Check it out!

Click here to read more about the April 2022 updates!

Power BI Dev Camp Session 22 768x460.jpg

Check it out!

Mark your calendars and join us on Thursday, May 26 at 11a PDT for a great session with Ted Pattison!