cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
BIXL
Resolver I
Resolver I

clear all slicer selection

Hi,

Is there a way to clear all current selection (kind of go back to the default slicer setting when the report was loaded) with just one action ?

47 REPLIES 47
Anonymous
Not applicable

Make everything in the page dafault to clear filter then add bookmark on the desired page. Then, create a button and go to action in visualizations box and select that bookmark. It will bring you back to the default view.image.pngAnnotation 2020-01-13 153142.png

 

 

dbliss
Regular Visitor

Here is my experience:

Below bar chart is my slicer.  If I select all choices, all 4 quarters appear in bar chart, as expected:

All QtrsAll QtrsSurprisingly the same happens when none is selected:No QtrsNo Qtrs We know that when we select 1 Qtr only, such as this, then only one Qtr shows:1 Qtr1 Qtr 
When I toggle the Q1 button (being the only one selected), so that nothing is selected, the bar chart shows all data - all 4 Qtrs (& blank), as in the second example above. 
If several boxes are selected, for example Q1 & Q2 & Q3  in slicer, I first click just one of the selected boxes, e.g., Q3,  The bar chart shows just the Q3 data.  Then I click on Q3 again, deselecting it, and thus all Qtrs are deselected.  The result is in  visualizations is as if all slicer boxes were selected, as in "No Qtrs" screen shot above.

 

You can Try using ISFILTERED() function... here is the sample:

If(ISFILTERED(Col_Name), sales, "")

 

 

ThomasDay
Impactful Individual
Impactful Individual

That's the say a slicer works from what I can see.  A slicer filters based on what you've checked.  If you don't check a box, there is no filter applied.  The blank appears if you have possible blank choices--or if you have relationships that somehow results in a blank.  I usually filter out the blanks on a page to prevent that...but remember if you do that, the ISFILTERED(for that column) will be true.  To get around that create a "dummy" duplicate and prevent blanks on that one.

Thanks for the tips.  Did you sense I was attempting answer the question: how to "clear all slicer selection"?  By your response, I don't think I succeeded. 

SwapnaChippagi
Frequent Visitor

Ya U can,by refreshing the page we can clear all slicers selected.

Suppose if we take the bookmark page(sample) ,give the same page link(sample) .

Hi Guys,

 

Here is the new option to clear the slicer in service, please use this option 

 

Reset.png

 

Regards,

Chetan K

This option(Reset to default) is appicable only when we publish to our cloud account.

vmakhija
Post Prodigy
Post Prodigy

ThomasDay
Impactful Individual
Impactful Individual

That's an interesting idea.  Seems doubtful it works for 3rd party embedding via Azure service (for example) since there is only 1 "user" license behind the scenes for every website user accessing reports.  Tom

SamerB
Frequent Visitor

In case this link hasn't been posted before on this thread, a feature that does that has been labelled as Planned by the PowerBI team.

http://linkis.com/ideas.powerbi.com/fo/F0770

SamerB
Frequent Visitor

I see that a feature that does that has been labelled as Planned.

http://linkis.com/ideas.powerbi.com/fo/F0770

 

 

jakellles
Regular Visitor

Hi,

 

So my bookmarked image (eraser) does deslect all slicers as intended. However, when I created my bookmark I had no slicers selected AND nothing selected within my matrix/tables. While the selecting the bookmarked link image will deselect slicers it seems it will not revert any selection made additionally within tables. will deslect slicers but keep any drilled/random matrix select.

 

So my questions is:

is there any way to force this bookmark to also revert the matrix cross selections? 

 

ThomasDay
Impactful Individual
Impactful Individual

Hey, let me jump in here.  I've been wrestling with these things...and clear all is pretty cool...though since bookmarks now capture crossfiltering, it seems like that can get "stuck" like you're describing.

 

What I just did for "clear all"  (versus toggle visuals showing) is right click the "clear all" bookmark created and update with "display" unchecked.  I think that's the crossfiltering from visuals.  Anyway, it seems to work.  But I guess the thing is to play around with what the bookmark saves.  On another it seems to work when I uncheck current page....go figure.  I think clicking fewer things might be the answer.

 

(Is that vague enough for you!  Sorry, I'm in the same space and sorting out as well.)  Tom

Anonymous
Not applicable

Hi Tom, I see that a bookmark, which I created in Dec and used it for clearing all the filters (reset filters), is no longer working as expected. We noticed this across the bookmarks that we have used in our reports. Dont know the exact reason but sure that it is not working as expected. Can you please confirm, if bookmarks are working as intended ?

 

 

ThomasDay
Impactful Individual
Impactful Individual

Well, I'm not sure what "not working as intended" means exactly but let me observe a few things.

  • This is in preview and each time they add features, I think there's a reason to examine the functioning of your bookmarks and I "update" them via the elipsis on the right.
  • Sometimes the new functions of bookmarks adds update check marks even!..so definitely update and see what the setting does.
  • I've found that if I click to set and then click to clear every slicer I want the book mark to act on--the bookmarks do their job.  If I don't, some of the slicers don't seem to have a saved state in the "clear all" bookmark--so that helps.
  • The retention of crossfiltereing is a bit of a mystery right now to me--so I have to experiment with that.  I'm sure it's not as hard as I make it but I can't quite figure that out.

Hope this helps.

@Anonymous

 

For what it's worth, I was having the same issue regarding bookmarks as a "clear slicers" function last week. (I am using an 'red X' icon as a clear all button linked to the bookmark on the page in the report - see picture).

clear slicers.PNG

 

 

 

 

(The exclamation mark is a warning sign to alert users that a selection or various selections in the slicers is/are active)

 

 

 

 

 

 

 

 

 

 

 

I first reported the issue on the Desktop forum Bookmark Bug on Desktop Forum and then thought it was worth reporting it as an issue on the Issues forum Bookmark Bug on Issues Forum

 

So to cut things short, the bookmark was inconsistent both from the report page itself (clicking on  the icon) and if navigating between pages. Yesterday I tried again an the "bug" has auto-magically gone away. At least that was the case on the Desktop App. I tried from the mobile app and the bug was still there when clicking the icon, but when I used the bookmark to go to the page itself from another page, the bookmark behaved as expected, and henceforth it worked fine from the page itself (icon).

 

So there is something going on. but in my case, it seems to have eventually cleared itself up (thus far...), albeit leaving an acute sense of discomfort with regards to reliability.

 

Probably not very helpful, but I thought it was worth commenting: "you are not alone in your woes!"

 

Regards,

 

Paul.

 

 





Did I answer your question? Mark my post as a solution!
In doing so, you are also helping me. Thank you!

Proud to be a Super User!
Paul on Linkedin.






ThomasDay
Impactful Individual
Impactful Individual

Hey Paul--I do think powerbi gets some fixes posted in the background especially on the preview features.  I know that visuals are "fixed" without "announcement" or notice on occasion. 

 

On one occasion, slicers didn't register on the waterfall visual when the model was first opened to a tab with a waterfall--but click on a different tab and then back and all was well.  That was fixed shortly thankfully.

 

With the bookmarks, I found that the fabulous attribute slicer (which is a "custom" slicer but made by Microsoft) has had trouble keeping up with releases.  On that one, the tokens don't get cleared using bookmarks.   

 

Anyway, I think it's probably fixed for you but I know it seems dicey!

 

Tom

Anonymous
Not applicable

@ThomasDay - hey, thanks for that clue. I believe, I had to update all my bookmarks once again (post Jan 18 release), and they started working again. And, I too noticed the Bookmarks weird behaviour with Attribute slicer custom visual. I shall check if they (custom visual folks), have pushed any updates or not.

jakellles
Regular Visitor

this works great on the slicers.

 

 

but what about when a selection is made iwithn a matrix/table - Ctrl+click on my bookmarked linked image does deslect any silcers as intended! But not a matrix cross selection? (while locking/creating the bookmark I view had nothing selected in the martrix) & no slicers selected. while the revert to no slicers works, it wont revert away from any matrix selection && slicer.

 

I guess the question is:

 

this work around will only deselect slicers?

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

March Update

Check it Out!

Click here to read more about the March 2021 Updates!

secondImage

The largest Power BI virtual conference

100+ sessions, 100+ speakers, Product managers, MVPs, and experts. All about Power BI. Attend online or watch the recordings.

secondImage

Experience what’s next for Power BI

See the latest Power BI innovations, updates, and demos from the Microsoft Business Applications Launch Event.