Reply
Frequent Visitor
Posts: 4
Registered: ‎10-25-2018
Accepted Solution

change format from text to number

Hi,

 

I have a set of columns with numbers that I noticed that PBI was treating as text. When going to modeling to convert there format to decimal numbers or any kind of Numbers format, it removes any decimal points in the numbers. For instance if I have a (2,28) in one cell, when converting its format to Numbers, the number becomes (228). how can I convert the number format from text to numbers without removing the decimal points?


Accepted Solutions
Highlighted
Established Member
Posts: 161
Registered: ‎01-02-2018

Re: change format from text to number

You can try the steps below.

 

Open Power Query Editor, remove any step in Query Settings that change your current Text Format into Number first.

2018-10-26_14-52-05.png

 

 

Then, select the orignial text column, right click to choose Change Type -> Using locale...2018-10-26_14-52-05.png

 

 

Then choose Data type and your Locale

2018-10-26_14-55-54.png

 

 

 

View solution in original post


All Replies
Regular Visitor
Posts: 20
Registered: ‎09-27-2018

Re: change format from text to number

It depends on your settings. 

You could use PowerQuery to transform these values from texts to numbers. 

Idk what values you have, but try replacing the text-values from . to , (dot to comma) or the other way around. 

Then try the transformation to decimals again.

 

Good luck Smiley Happy

Community Support Team
Posts: 7,323
Registered: ‎05-02-2017

Re: change format from text to number

Hi @MOHUS,

 

You should set a proper format for the original data. Please refer to the snapshot below. 

change-format-from-text-to-number

 

Best Regards,
Dale

Community Support Team _ Dale
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Established Member
Posts: 161
Registered: ‎01-02-2018

Re: change format from text to number

You can try the steps below.

 

Open Power Query Editor, remove any step in Query Settings that change your current Text Format into Number first.

2018-10-26_14-52-05.png

 

 

Then, select the orignial text column, right click to choose Change Type -> Using locale...2018-10-26_14-52-05.png

 

 

Then choose Data type and your Locale

2018-10-26_14-55-54.png

 

 

 

Frequent Visitor
Posts: 4
Registered: ‎10-25-2018

Re: change format from text to number

Exactly, works fine now thanks. Smiley Happy