cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
pjpreddy2 Frequent Visitor
Frequent Visitor

bug in Power Bi using multiple screens

Hi,

 

I recently got moved my workspace and I have additional monitors.  So when I open Power Bi and move it from the laptop screen to the new monitor, I hover over the and it duplicates the work space and nothing I click on will work.  I've tried adjusting the screen resolution, but it only works on the laptop screen. 

 

I also uninstalled and reinstalled but keep getting the same issue.

 

Thoughts?

 

Issue.PNG

1 ACCEPTED SOLUTION

Accepted Solutions
pjpreddy2 Frequent Visitor
Frequent Visitor

Re: bug in Power Bi using multiple screens

Thanks to @Toddlariviere for the solution, here's how it works...

 

I found a solution for my End User

 

We had to change scalling for the Application only (not for the monitors)

On your desktop, right click the program you want to reduce scaling on and select 'Troubleshoot Compatibility'. This will open a troubleshooting window.

Click 'Troubleshoot Program' and select 'The program opens but doesn't display correctly'.
This will show the compatibility settings Windows has selected for the program. It should say 'Display settings: Scaling on high DPI'.

Test the program. Just use the button in the troubleshooting window. If you like how it appears, click Next, then you're done!

7 REPLIES 7
pjpreddy2 Frequent Visitor
Frequent Visitor

Split Screen Saddness Bug

Issue.PNGI posted this on Desktop but haven't gotten a response, so someone told me to post this hear. 

 

I recently got moved my workspace and I have additional monitors.  So when I open Power Bi and move it from the laptop screen to the new monitor, I hover over the and it duplicates the work space and nothing I click on will work.  I've tried adjusting the screen resolution, but it only works on the laptop screen. 

 

I also uninstalled and reinstalled but keep getting the same issue.

 

Thoughts?

Community Support Team
Community Support Team

Re: bug in Power Bi using multiple screens

Hi @pjpreddy2,

 

Do you use the same system on different devices?

 

Regards,

Yuliana Gu

Community Support Team _ Yuliana Gu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
pjpreddy2 Frequent Visitor
Frequent Visitor

Re: bug in Power Bi using multiple screens

Yes, sort of.  Different monitors & docking station but same models.  The problem started after I uploaded the newest version.

Community Support Team
Community Support Team

Re: bug in Power Bi using multiple screens

Hi @pjpreddy2,

 

It looks like an issue. I would suggest you create a support ticket here for further analysis.

 

Regards,

Yuliana Gu

Community Support Team _ Yuliana Gu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
pjpreddy2 Frequent Visitor
Frequent Visitor

Re: bug in Power Bi using multiple screens

Thanks to @Toddlariviere for the solution, here's how it works...

 

I found a solution for my End User

 

We had to change scalling for the Application only (not for the monitors)

On your desktop, right click the program you want to reduce scaling on and select 'Troubleshoot Compatibility'. This will open a troubleshooting window.

Click 'Troubleshoot Program' and select 'The program opens but doesn't display correctly'.
This will show the compatibility settings Windows has selected for the program. It should say 'Display settings: Scaling on high DPI'.

Test the program. Just use the button in the troubleshooting window. If you like how it appears, click Next, then you're done!

jwgildea Occasional Visitor
Occasional Visitor

Re: bug in Power Bi using multiple screens

I have been struggling with this for weeks.  Thank you!

SeanHenderson New Member
New Member

Re: bug in Power Bi using multiple screens

For those of you like myself that are still struggling with this, I've figured out a solution that works with current versions of Windows 10. Currently, the compatibility troubleshooter doesn't include the ability to change DPI settings. Here's what to do:

 

Make sure you are using a downloaded copy of the program rather than the Microsoft store version, otherwise you

won't be able to make changes to the program properties. Get the download from the Power BI service.

 

Navigate to the PBIDesktop file in Program Files > Microsoft Power BI Desktop > bin

 

Right click on the PBIDesktop file and select properties. Click on the "Compatibility" tab. Click on "Change high DPI settings".

 

Click on the box for "Use this setting to fix scaling problems for this program instead of the one in Settings". Then where it says "Use the DPI that's set for my main display when" select "I open this program" from the drop down menu. 

 

Click Ok, click apply. Reopen Power BI Desktop. It should work fine and let you switch from between 1 monitor or 2 at will without any issues.