cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
KyleAdam
Frequent Visitor

Year/Quarter/Month/Day not showing up on X axis for my dataset

I have a Date/Time dataset (which is a custom column I've converted so I'm guessing that's the reason why it's not working) that isn't showing a Year/Quarter/Month/Day for the x axis. At the moment it's showing every single ticket date by the specific date, which is obviously not what I want since I have over a 1000, I want to see a monthly record otherwise it's a mess, as you can see here below:

 

KyleAdam_0-1611668249642.png

For the x axis there should be a choice to filter your dates into a Year/Quarter/Month/Day measurement. Like it is here for another Date/Time dataset that I have: 

 

pbi selection.png

I just want my new converted datasets to have the same features the other Date/Time datasets have. The new Custom Columns that I created for the converted datasets were because the original datasets were millisecond 13-digit Time Stamps that I converted into an original Date/Time format. As you can see below, they converted perfectly just as intended: 

custom.png

 

So what could be the issue here for why it doesn't have the same graph features as a standard Date/Time dataset has?

 
 
 

 

 

 

1 ACCEPTED SOLUTION
Pragati11
Super User III
Super User III

Hi @KyleAdam ,

 

Whenever you move a DATE type column to a chart's x-axis, then you should select the following option to make the hierarchy work:

Pragati11_0-1611670153325.png

 

 

Once you do this you get a drill-down icon on the top right of your chart which you can use to drill to the month level:

Pragati11_1-1611670076288.png

 

Thanks,

Pragati

 





If this helps, Appreciate a KUDOS!
Did I answer your question? Mark my post as a solution!


Proud to be a Super User!




View solution in original post

3 REPLIES 3
KyleAdam
Frequent Visitor

Thank you guys, such a simple solution, It was really puzzling me for a while now and I couldn't find a solution. Appreciate it! 

NikhilKumar
Super User II
Super User II

I would say couple of things to check-

1. Please check if the time intelligence is enabled for the report.

2. The Created Time filed on the axis of the visual, you can see a downward arrow , click over there and see if there is an option for date hierarchy.

3. Create a date hieracrcy for the Created Time field.


Nikhil
Hit the Thumbs-up button if you find this informative!!
Did I answer your question? Mark my post as a solution!


Proud to be a Super User!

Pragati11
Super User III
Super User III

Hi @KyleAdam ,

 

Whenever you move a DATE type column to a chart's x-axis, then you should select the following option to make the hierarchy work:

Pragati11_0-1611670153325.png

 

 

Once you do this you get a drill-down icon on the top right of your chart which you can use to drill to the month level:

Pragati11_1-1611670076288.png

 

Thanks,

Pragati

 





If this helps, Appreciate a KUDOS!
Did I answer your question? Mark my post as a solution!


Proud to be a Super User!




View solution in original post

Helpful resources

Announcements
User Groups Public Preview

Join us for our User Group Public Preview!

Power BI User Groups are coming! Make sure you’re among the first to know when user groups go live for public preview.

March Update

Check it Out!

Click here to read more about the March 2021 Updates!

secondImage

The largest Power BI virtual conference

100+ sessions, 100+ speakers, Product managers, MVPs, and experts. All about Power BI. Attend online or watch the recordings.