cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Post Patron
Post Patron

Why isn't this USERELATIONSHIP measure working?

Hi,

 

Been trying to work this out and I'm struggling. Does anyone know why this measure isn't working? I feel like it's something plainly obvious 

 

 

Completions -  Count = SUM(Completions[Completions]) 
Completions - - Relationship = 
CALCULATE(Completions[Completions -  Count],
USERELATIONSHIP('Date'[Full Date], Completions[Date]) )

 

help 1.PNGhelp 3.PNG

 

I checked the Date type to make sure it's the same in both tables, it is. I checked the data type of the sum column. I checked the relationships. Is there anything I'm missing?

 

https://www.dropbox.com/s/ftn5q3g388azvn5/Completions%20-%20Copy.pbix?dl=0

 

Cheers,

Mike

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Super User IV
Super User IV

Re: Why isn't this USERELATIONSHIP measure working?

@michaelknight94 , I made it 1 to M from date to table and it worked

Find attached file after signature



Did I answer your question? Mark my post as a solution! Appreciate your Kudos!!
My Recent Blog -Week is not so Weak Connect on Linkedin

Proud to be a Super User!

View solution in original post

4 REPLIES 4
Highlighted
Super User IV
Super User IV

Re: Why isn't this USERELATIONSHIP measure working?

@michaelknight94 , I made it 1 to M from date to table and it worked

Find attached file after signature



Did I answer your question? Mark my post as a solution! Appreciate your Kudos!!
My Recent Blog -Week is not so Weak Connect on Linkedin

Proud to be a Super User!

View solution in original post

Highlighted
Post Patron
Post Patron

Re: Why isn't this USERELATIONSHIP measure working?

Knew it would be something as simple as that. Cheers @amitchandak 

Highlighted
Solution Sage
Solution Sage

Re: Why isn't this USERELATIONSHIP measure working?

In additon to Amit's answer you don't need USERELATIONSHIP if you only have 1 relationship between tables.


Thank you,
Antriksh Sharma
Highlighted
Post Patron
Post Patron

Re: Why isn't this USERELATIONSHIP measure working?

Hi @AntrikshSharma 

 

This is only a small part of the dataset, there is another dataset which I removed for the purpose of getting some help, and due to gdpr.

 

Cheers,

Mike

Helpful resources

Announcements
August 2020 Community Challenge: Can You Solve These?

August 2020 Community Challenge: Can You Solve These?

We're excited to announce our first cross-community 'Can You Solve These?' challenge!

July 2020 Community Highlights

July 2020 Community Highlights

Learn about the exciting things that happened in July.

Featured Data Story of The Month

Featured Data Story of The Month

All Data Stories Gallery contributions are reviewed for each month. We select a contribution and feature the community member the following month.

Power BI Dev Camp - Developing with .NET Core

Power BI Dev Camp - Developing with .NET Core

Learn how to develop custom web applications for Power BI using .NET Core 3.1 and .NET 5.

Power BI Desktop August 2020 Update

Power BI Desktop August 2020 Update

We have great updates this month! Click the link for the video with more info.

Top Solution Authors
Top Kudoed Authors