cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
uBoatCaptain
Helper I
Helper I

Why is column not summing in a table?

ColumnSetup

 

Column properties

I have a column that is setup like in the image that is not summing. When I use it in a table it does not summarize by fund, and the table does not provide a total. The column seems properly set up to sum but Power BI appears to see it differently.

Below is side-by-side a table that is summing and totaling (on a different column) and one that is not. Yes I have checked that the column on the left has the same settings on the ribbon as the column on the right.

Two tables

1 ACCEPTED SOLUTION

Check formats, If it is number stored as Text then it wont offer to Sum as Adding Text is unpossible. Make sure it is a number format. 

 

The other thing I check first is to select the table and visualizations section make sure the values are not set to do not summarize when you click the down arrow beside them.

View solution in original post

6 REPLIES 6
uBoatCaptain
Helper I
Helper I

Thanks for the tip on uploading images. Here they are (the drag and drop was not working yesterday).

This is the column set up on the modeling ribbon. Below that are two tables that should be giving the same summarized result. The one on the left uses a column that is derived from the column on the right. I ought to be able to have the column on the right summarize like the column on the left.

ColumnSpec.jpgTwoTables.jpg

Check formats, If it is number stored as Text then it wont offer to Sum as Adding Text is unpossible. Make sure it is a number format. 

 

The other thing I check first is to select the table and visualizations section make sure the values are not set to do not summarize when you click the down arrow beside them.

Thanks DSimma. It was the table visualization choosing a different summarization than is the default on the column.

 

Before I mark that as the solution, does anyone have an explanation why two columns that appear to have exactly the same properties on the Modeling ribbon pick up a different default when used in a table?

uBoatCaptain
Helper I
Helper I

My screen shots do not appear to be showing. Maybe someone can share the magic trick for making those work as well.

@uBoatCaptain Make sure that when you click the "Photos" button ( I assume you are grabbing a snippet of the table or something that creates an image), select the image, and wait until the image loads in the preview pane... kinda weird upper right corner. THEN, click ok, if you do it prematurely the image won't load.

As to the sum.. without the image it's hard to tell, but is the data type correct on the column?


Looking for more Power BI tips, tricks & tools? Check out PowerBI.tips the site I co-own with Mike Carlo. Also, if you are near SE WI? Join our PUG Milwaukee Brew City PUG
uBoatCaptain
Helper I
Helper I

My screenshots do not appear to be showing. Maybe someone can share the magic trick for making those work as well.

Helpful resources

Announcements
Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

charticulator_carousel_with_text (1).png

Charticulator Design Challenge

Put your data visualization and design skills to the test! This exciting challenge is happening now through May 31st!

May UG Leader Call Carousel 768x460.png

What difference can a User Group make for you?

At the monthly call, connect with other leaders and find out how community makes your experience even better.

Power BI Release May 2022 768x460.png

Check it out!

Click here to read more about the May 2022 updates!