cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
HamidBee
Super User
Super User

Why are my reports not showing in the 'Test' and 'Production' workspace in the deployment pipeline?

 
I have a trial account on the Power BI Service. I have a simple Excel file with some data, I created a report from this and published it onto the service. I created a deployment pipeline on the Power BI Service and ensure I deplloyed the same report on all woekspaces:

 

HamidBee_0-1653401601961.png

 

Here it is what is in each workspace:

 

HamidBee_1-1653401602264.png

 

Here is what the stage 1 report looks like:

HamidBee_2-1653401602232.png

 

Here is what the stage 2 and 3 report looks like:

HamidBee_3-1653401602589.png

 

Does anyone know why this is?

 

Thank you, 

1 ACCEPTED SOLUTION
HamidBee
Super User
Super User

The solution is that I had to setup a gateway connection and schedule refresh as the datasource itself was on premises. I had uploaded the report from Power BI Desktop. I still don't fully understand why it is, I just know that's why. After I created a gateway and uploaded the data everything worked fine. 

View solution in original post

1 REPLY 1
HamidBee
Super User
Super User

The solution is that I had to setup a gateway connection and schedule refresh as the datasource itself was on premises. I had uploaded the report from Power BI Desktop. I still don't fully understand why it is, I just know that's why. After I created a gateway and uploaded the data everything worked fine. 

Helpful resources

Announcements
September Update

Check it Out!

Click here to learn more about the September 2022 updates!

Power BI Show episode 9

The Power BI Community Show

Watch the playback when Priya Sathy and Charles Webb discuss Datamarts! Kelly also shares Power BI Community updates.

Power BI Dev Camp Session 26

New Date - Check it Out!

Mark your calendars and join us on Thursday, October 6 at 11a PDT for a great session with Ted Pattison!

Top Solution Authors