cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Lyhis
Helper IV
Helper IV

Weird date slicer bug

Hi

 

Sadly I can't show any examples because of sensitive data so I'll try to explain as detailed as possible.

 

I have 3 table visuals and 1 date slicer - all data comes from 1 sql table.

Date slicer right now starts with 25.jan until today, updates everyday.

 

1st table:

Item IDIDDateStatusImei codeTable1 ID
F214225.01.2021 14:11:25Passed592158218521814
F521528.01.2021 12:41:45Failed562162216215112
F621326.01.2021 19:21:52Failed521995219592511
F871325.01.2021 11:42:11Passed521521566121425

 

2nd table: ( shows total scans )

Item IDScansPassed scansFailed scans
F87119217319
F621706010
F521201010
F214532

 

3rd table: ( shows failed scans only )

Item IDTable1 IDQuantityIMEI codeDescription
F5211215621622162151Some old junk
F6211125219952195925Some more junk

 

Now when I have my date slicer from min to max ( showing all data avaivable ) and I click on table 1 on row item ID F521 for example then all the other tables refresh correctly, showing the data about this 1st table pick only. 

However when I move the slicer and choose 1 specific date for example 28.01.2021 it once again refreshes all tables correctly accordingly to that date BUT when I click on F521 in table1 the other 2 tables show blank but should show data about F521. ( Remember it does this correctly when I don't touch the date slicer. ) 

 

I already checked: If "Edit interactions" isnt blocking some data <- it's not- turned to "filter" in every table.
I added Date column to other 2 tables aswell to see if maybe the dates are somehow wrong but no it shows the exact date and time.
Since data comes from same table there can not be and relationship problems. 
There are no filters. ( Note when I tried to filter out 2 useless items from table 1 then it broke for some reason even when date slicer wasn't touched - didn't show any data on any other table when 1 item was selected in table 1 - don't know why )

 

My question is how can it work correctly when date slicer is not touched but brakes after date slicer is modified while all data comes from same table. - no custom columns either.

Note2: When I remove Date column from table1 then other tables refresh correctly even if date slicer is modified. 
Note3: I only have 1 date column that I use.

 

3 REPLIES 3

You don't mention how the tables are joined. This information is required to understand the problem. 



* Matt is a Microsoft MVP (Power BI) and author of the Power BI Book Supercharge Power BI.

Joined? What do you mean by that? Theres 1 table from SQL DB with 10 columns, there aren't 2 tables. Sorry my initial post was confusing, fixed it

Oh, you have 3 table visuals, not 3 tables. That's different. You need to build a dimensional model. Create a calendar dimension table and an item dimension table - both tables should contain all the unique values from your date column and items column. Join them with a 1 to many relationship dim to the main table. Then put the slicer on the date dim table and another on the item table. See how that goes. 



* Matt is a Microsoft MVP (Power BI) and author of the Power BI Book Supercharge Power BI.

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

March Update

Check it Out!

Click here to read more about the March 2021 Updates!

secondImage

The largest Power BI virtual conference

100+ sessions, 100+ speakers, Product managers, MVPs, and experts. All about Power BI. Attend online or watch the recordings.

secondImage

Experience what’s next for Power BI

See the latest Power BI innovations, updates, and demos from the Microsoft Business Applications Launch Event.