cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
rmachado Member
Member

Visual not working when I had one field due to Visual exceed error (powerBi Online)

I have a dashboard with a table that has a lot of fields and I use a slicer to filter the data on it that has 3 values (strings).

In the online service I get the visual exceded error in one of the value that I filter (the other two work fine).

The table that is used in the visual has the 713 rows.

 

If I remove "just" ine field it works perfectly.

 

The field I remove is buit in this manner:

Actual Planned Code Ready = CALCULATE (
    VALUES ( 'public Planned Code Ready'[Planned Code Ready] );
    TOPN (
        1;

            FILTER('public Planned Code Ready';'public Planned Code Ready'[issueid] = 'public jiraissue (2)'[id])
        ;
        'public Planned Code Ready'[created]; DESC
    )
)  

The Planned Code Ready has the following info:

image.png

 

What can I do to improve the performance on this formula? How can I lower the memory consumption and how to debug it?

 

Thanks

6 REPLIES 6
Moderator v-yuezhe-msft
Moderator

Re: Visual not working when I had one field due to Visual exceed error (powerBi Online)

@rmachado,

Is there any possibility that you can share me the PBIX file so that I can reproduce?

Regards,
Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
rmachado Member
Member

Re: Visual not working when I had one field due to Visual exceed error (powerBi Online)

@v-yuezhe-msftHow can I do that?

 

Thanks

Moderator v-yuezhe-msft
Moderator

Re: Visual not working when I had one field due to Visual exceed error (powerBi Online)

@rmachado,

You can upload PBIX file to OneDrive and post shared link of it here.

Regards,
Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
rmachado Member
Member

Re: Visual not working when I had one field due to Visual exceed error (powerBi Online)

Thanks @v-yuezhe-msft, can I send you the link via MP?

Moderator v-yuezhe-msft
Moderator

Re: Visual not working when I had one field due to Visual exceed error (powerBi Online)

@rmachado,

You can send me the link through Private message.

Regards,

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
rmachado Member
Member

Re: Visual not working when I had one field due to Visual exceed error (powerBi Online)

@v-yuezhe-msftDone.

 

Thanks