cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
fishleaf
Helper II
Helper II

Very Slow Oracle Connection Speed

Hello,

 

I'm trying to connect to an on-primise Oracle database. I followed this instrucution and installed ODAC and instant client. 

 

This is the connection speed if I use sqldeveloper and each row has 140 fields. At least I can fetch like 80 rows/second. 

 

Capture.PNG

 

However, when I use Power BI Desktop and connect the same database and the same table, I can only import 5-8 rows/second. I have 100K rows in this table, so this is going to take forever...

 

Then I connected to a remote desktop to a server, Power BI can load like 500 - 800 rows per second... but I can't do the development work on my remote desktop..

 

Did anyone have the simliar issue? Did I set up ODAC on my laptop wrong? Or there's other componment I didn't install?

 

Thank you,

 

Matthew 

14 REPLIES 14
StianHog
Frequent Visitor

Same here. Slow Oracle load compared to Toad. 

Anonymous
Not applicable

Same here.Still extremely slow.Takes forever.

Hi, 

As a test we updated our (way to old) oracle version to 12.2. That improved the speed a lot. From 16 to 4 minutes. 

Br

Stian

Anonymous
Not applicable

Yeah, i have the same slow performance accessing Oracle Database with the 64-bit ODAC installed.

 

Is there any update on it? I have checked with other client tools like PLSQL Developer, Toad etc, they retrieval is far faster as compared to Power BI Desktop. What we are missing here? Please some one from the product team should answer that question with the rectification.

Anonymous
Not applicable

In my case the situation got solved just by adding ' in the WHERE clause

something like SELECT A, B, C, D WHERE Key_Partition = '2019180512345'

because Oracle was doing an implicit conversion

 

VanLy
Frequent Visitor

The post was made in 2016...And the connection is still slow...any progress or updates?

It takes forever to load

abkgo
New Member

Hi, Sorry for replying to an old thread, but was this issue ever solved? - I see a few other threads reporting the same issue but with no solution. I am facing the same problem - data load from Oracle is much slower compared to other DBs (Postgres, SQL Server), especially when table has a lot of columns and/or the column size is large (ex. VARCHAR2(4000)). Tableau loads the same data at least an order of a magnitude faster - so its definitely not a network speed issue.   

 

I'd be really interested in an update on this one too.

 

I completely echo abkgo's comment - I'm connecting to an Oracle view I have created with both PowerBI and Tableau, yet the extraction time between them is very different (Tableau being significantly faster). 

 

Also - probably a separate issues I know, but when I publish a PBI book to the PowerBI service and connect via a content gateway that has been installed, the performance seems somewhat hit and miss. I'm extracting about 2.5m rows on my desktop, which takes around 20-30 however the same extraction in the PBI service takes about 2hrs and frequently times out (because its hitting the 2hr limit).

Would be interested in an update as well, since we have big issues with extracting data out of an Oracle DB

 

Export of 134k rows, 12 mixed columns.

Oracle SQL Developer: approx 1 minute

Power BI: 20 minutes

arify
Microsoft
Microsoft

Hi Matthew,

 

When connecting the Oracle Database, in the prompt (where you enter your server name etc.) Is the checkbox "Include relationship columns" checked? If it is, can you check the performance without that checked?

 

If you want it to be faster with that option checked, a significant Oracle performance improvement is in our near-future plans 🙂

 Hello Arify,

 

Sorry for replying to you late. I tried your method to uncheck the box. But the speed didn't improve that much... 

 

I guess that's mainly my connection speed issue. Maybe I should wait for the new version release. I don't think I missed any key Orcale add-in to install, right?

 

Thank you,

 

Matthew

If unchecking that checkbox didn't make it faster, then it's probably your connection speed.. Can you try some other tools to see if they're faster? (Make sure the results aren't cached, otherwise it would appear fast 🙂 )

Thank you for the information and the insider news! I will double check that checkbox and let you know later today! Thank you, Matthew

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

November Power BI Update 768x460.png

Check it Out!

Click here to read more about the November 2021 Updates!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.