cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper I
Helper I

VLookup help

Hi,

 

I need some help with Power BI pro. I am trying to replicate a vlookup we used in excel which basically is this:


=IFERROR(VLOOKUP(B3*1,Mapping!$P:$Q,2,FALSE),"No Group")

 

I have been able to use Column 1 = RELATED('Report 2'[Group]) which pulls the correct field but on instances where there is no match I want it to display "No Group"

 

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Super User III
Super User III

Re: VLookup help

 

Hi @Bilal_321321

 

the Lookupvalue formula returns blank if it doesn't have a match in the lookup (lookpvalue formula) try changing your formula to this:

 

Column = SWITCH (
    TRUE (),
    ISBLANK (
        LOOKUPVALUE ( Report2[Group], Report2[GroupID], Report1[GroupID] )
    ), "NoGroup",
    LOOKUPVALUE ( Report2[Group], Report2[GroupID], Report1[GroupID] )
)

 

Regards,

MFelix


Regards

Miguel Félix


Did I answer your question? Mark my post as a solution!

Proud to be a Super User!

Check out my blog:

Power BI em Português





View solution in original post

4 REPLIES 4
Highlighted
Super User III
Super User III

Re: VLookup help

Hi @Bilal_321321,

 

You need to do a formula with the following sintax:

 

 

Column =
IFERROR (
    LOOKUPVALUE ( Table[Result], Table[Search_Value], "Value_to_Search" ),
   "No Group"
)

 

Regards,

MFelix

 


Regards

Miguel Félix


Did I answer your question? Mark my post as a solution!

Proud to be a Super User!

Check out my blog:

Power BI em Português





Highlighted
Helper I
Helper I

Re: VLookup help

Hi MFelix,

I must be doing something wrong, the LOOKUPVALUE is working but for instances it's not got a value the "No Group" is not populating. This is the formula i have created so far:

 

Column = IFERROR ( LOOKUPVALUE('Report 2'[Group],'Report 2'[GroupID],'Report1'[GroupID]) , "No Group")

 

The 'Report 2'[Group] is the table and column I'm looking at, 'Report 2'[GroupID] is the linked field I am searching based on 'Report'[GroupID] and the "No Group" should appear instead of blanks.

 

I'm probably making an obvious mistake but can't see it.

 

Thanks

Bilal

 

Highlighted
Super User III
Super User III

Re: VLookup help

 

Hi @Bilal_321321

 

the Lookupvalue formula returns blank if it doesn't have a match in the lookup (lookpvalue formula) try changing your formula to this:

 

Column = SWITCH (
    TRUE (),
    ISBLANK (
        LOOKUPVALUE ( Report2[Group], Report2[GroupID], Report1[GroupID] )
    ), "NoGroup",
    LOOKUPVALUE ( Report2[Group], Report2[GroupID], Report1[GroupID] )
)

 

Regards,

MFelix


Regards

Miguel Félix


Did I answer your question? Mark my post as a solution!

Proud to be a Super User!

Check out my blog:

Power BI em Português





View solution in original post

Highlighted
Helper I
Helper I

Re: VLookup help

Amazing!!! Thanks So much for your help @MFelix. It has worked perfectly

Helpful resources

Announcements
Community Blog

Community Blog

Visit our Community Blog for articles, guides, and information created by fellow community members.

Using the Community

Using the Community

Need help with the Power BI Community? Our 'Using the Community' support articles are a great place to start.

Community Summit North America

Community Summit North America

Innovate, Collaborate, Grow. The top training and networking event across the globe for Microsoft Business Applications

Power Platform 2020 release wave 2 plan

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors