cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
vvillama
Frequent Visitor

Unexpected Mashup Engine Containers constantly processing

Hi,

 

Since a couple of releases ago, the Desktop app has become unmanageable for my computer. It is an i5 with 8gb of RAM.

Upon inspecting what's going on, here's what i see.

Whenever the desktop app is opened, just the app, no report, it takes 1gb of RAM straight away.

Opening any report, and even having the option "Allow data preview to download in the background" disabled, power bi triggers three mashup evaluation containers that i don't know what are doing. The option is disabled, the report is idle, i have no power query window open... what are those mashup containers gathering?

Take a look at this screenshot, these are the processes that are triggered upon just opening a 10mb report, and doing nothing on the desktop, just staring at the main page. There's an element without name (1) that is taking 1gb of memory and three evaluation containers (2) taking 750mb of memory and around 75% of the CPU, i repeat, without doing anything on the desktop app:

mashup container.JPG

 

I can leave the app open with the report idling and these three threads will not stop anytime, however the amount of CPU and RAM they use may vary. Eventually, the "no name" element, will display the report's name.

If i open another report we have, 80mb pbix, this is what happens:

mashup container 2.JPG

 

This, just by opening the report, "Allow data preview to download in the background" is still disabled.

If i try to edit a query -which is being sourced from dataflows so the refresh and or the preview is usually very fast-, the preview takes ages to provide results. The same query, if it's closed and changes applied, will take seconds to retrieve the data. Why executing the whole query works as intended, but the preview which is basically getting the first 1000 results is not able to finish?

What i can see that may explain this behaviour, is that while working on power query and manually triggering a preview refresh, no new mashup engines are being triggered: the same three that were previously running keep on doing whatever they're doing, but no new ones appear. However, when i close and apply, there are indeed new mashup engine threads triggered on top of that three.
In other words, those three threads running right away since the file is opened, seem to be preventing the preview threads from running.

All this renders the power query interface useless. It is very hard to do anything there in these terms.

This report used to work just fine, queries could be edited and there was no drama to get the data in the preview. It usually takes ten minutes to refresh the whole report, and it takes around the same time when refreshed in the service.

Yesterday it took around an hour to have it refreshed from the desktop app, and i suppose it is because those three mashup engine threads were interfering in the normal report refresh.

Can anybody please shed some light around what these three mashup engine threads are doing or what is triggering them?

Is there anything that can be done to shut them down?

Thanks in advance for your help.

 

 

 

 

 

 

10 REPLIES 10
Syndicate_Admin
Administrator
Administrator

Did anyone manage to solve this problem? I just present the same thing and I can't get information regarding what triggers the mashup event.

jflord
New Member

Has anyone find a solution to this thread?

 

I'm experiencing the same issues with 3 Mashup Engines.

vvillama
Frequent Visitor

Hello everyone,

 

@v-jayw-msft , since the last update (2.85.985.0 64-bit sept 2020), where enhanced metadata is now generally available, this issue is striking back.

 

Before, we were able to disable the preview feature and the desktop app could be used normally.

 

Simply opening a report that loads no data (all queries have load disabled), takes up 4.5 gb of memory and 3 idling mashup evaluation containers are constantly open while there's no data load request specifically triggered by the user.

 

We should have more control about this. I need to be able to ensure that the desktop is focusing on what i need to do at the moment, and not whatever tasks it thinks it has to perform. And if these tasks are so necessary, at least inform the user about what's going on, and provide an expectation of when these tasks are going to finish.

 

Are there any investigations in progress as to why this is happening and when will it be solved?

 

Thanks in advance for your help.

malegriaa
New Member

Hello!

I have the same problem and I would like to know if they could come up with a solution.

I'm attentive!

Best regards.

jordisastre
New Member

I'm experiencing the same issue, with different types of reports, they worked flawlesly up until march version but from march version it started consuming absurd amounts of cpu just sitting idle on unnecesary mashup engine containers

 

For what can i see mashup container is trying to update data on the background event if not needed to, it's extremely frustrating because i cannot really work with any project as it makes my pc crawl due to the high cpu usge and temp on my machine

 

Happens both on x86 and x64 versions

 

It gets even triggered on a template load BEFORE you fill the parameters, so it should be not loading anything, just seems that the mashup containers are trying to retrieve and process the data before it's needed or even available.

 

i have just deployed a clean machine to azure just to test it and it works better... in that machine (it's only 4 cores and my machine is 4 x 2 with hyperthreading) and there it only spawns ONE mashupcontainer that uses cpu and it ends fast, less than a minute

We have narrowed down to enhanced metadata format migrated reports, the old ones do never trigger the issue.

 

Also i have found that if i clear the credentials to data source access the mashup container does not spawn until i set them again, but at that very moment they start again, it even locks the credentials dialog of the datasource to end until the mashup container is killed, it seems that is waiting for its evaluation to end

v-jayw-msft
Community Support
Community Support

Hi @vvillama ,@BIntelligence ,

 

Please check the offical document about the minimum requirements of Power BI Desktop.

https://docs.microsoft.com/en-us/power-bi/fundamentals/desktop-get-the-desktop#minimum-requirements 

Minimum requirements

The following list provides the minimum requirements to run Power BI Desktop:

  • Windows 7 / Windows Server 2008 R2, or later

  • .NET 4.5

  • Internet Explorer 10 or later

  • Memory (RAM): At least 1 GB available, 1.5 GB or more recommended.

  • Display: At least 1440x900 or 1600x900 (16:9) recommended. Lower resolutions such as 1024x768 or 1280x800 aren't recommended, as certain controls (such as closing the startup screen) display beyond those resolutions.

  • Windows display settings: If you set your display settings to change the size of text, apps, and other items to more than 100%, you may not be able to see certain dialogs that you must interact with to continue using Power BI Desktop. If you encounter this issue, check your display settings in Windows by going to Settings > System > Display, and use the slider to return display settings to 100%.

  • CPU: 1 gigahertz (GHz) or faster 32-bit or 64-bit x86 processor recommended.

And refer to the topic below about Microsoft mashup evaluation container.

https://community.powerbi.com/t5/Service/What-is-Microsoft-mashup-evaluation-container-How-it-impact... 

 

Best Regards,

Jay

Community Support Team _ Jay
If this post helps, then please consider Accept it as the solution
to help the other members find it.

Hi @v-jayw-msft ,

 

Thanks for your reply.

 

Regarding the minimum requirements, i'd say the computer i'm using is covering them.

 

Regarding the link about mashup engine you're providing, i apologize in advance, but i fail to see the connection with the issue discussed in this thread.

 

Just to summarize, the same set of queries, placed in two different pbix files with the same settings, are providing different behaviour: One file is triggering three mashup engine threads upon opening and the other one is not.

 

There may be a hidden setting in one of the files that is causing this, or there may be another explanation.

 

The point being that these three mashup engine threads have not been triggered on purpose by any action made by me, such as refreshing the model or editing a query through the transform data UI, cannot be killed through task manager, and are "sucking" precious computer resources which are degrading the overall interaction with the app, making any edit anywhere a pain.

 

The purpose of this post is to learn what's going on, why is it occurring and how can we prevent it from happening.

 

Thanks and kind regards,

vvillama
Frequent Visitor

I've made a quick test, I created a new pbix and copied over all the queries from the other report. The behaviour has been different, and this is what task manager displays upon opening the file:

 

mashup container 5.JPG

 

As you can see, there are no mashup engines triggered when the file is opened.

 

This means that there's something within the original file that is somehow triggering those mashup engines upon file opening.

 

Anybody has an idea about how to track the source of the trigger?

 

Thanks again,

BIntelligence
Frequent Visitor

Same over here, including another strange error I'll post in this forum.

Helpful resources

Announcements
August 1 episode 9_no_dates 768x460.jpg

The Power BI Community Show

Watch the playback when Priya Sathy and Charles Webb discuss Datamarts! Kelly also shares Power BI Community updates.

Power BI Dev Camp Session 24 without aka link and time 768x460.jpg

Ted's Dev Camp - July 28, 2022

Watch Session 24 of Ted's Dev Camp along with past sessions!

Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Top Solution Authors
Top Kudoed Authors