cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
gonrodrigues
Helper III
Helper III

Unexpected Error

Hi, I am getting an 'unexpected error' when I try to click on something in PowerBI Desktop on my local windows machine.

Yesterday i was working normally, now i can't even click on a graphic...

 

Can someone help me please.

 

"[$rootscope:inprog] $digest already in progress

http://errors.angularj.org/1.5.0/$rootscope/inprog?p0=%24digest"

 

and i also get another error:

 

"Cannot read property 'xMin' of undefined"

 

3 REPLIES 3
heathernicole
Continued Contributor
Continued Contributor

@gonrodrigues 

JUST ran into the same issue - it kept throwing the same error over and over and over... you get it. 

 

Here's what I did -

  1. get that error dialog box to close out. 
  2. Go into Edit Queries on the Home Tab
  3. For my case - I deleted the most recent dataset I had added 
    1. Applied the changes
    2. Then saved the report
  4. The close completely out of Power BI
  5. Reopen the Report

Whatever visuals you created with that dataset will be gone - but you'll be able to get in there and redo them. 

 

Not exactly sure what caused it - but my guess is it got in some kind of a loop either while trying to publish data or while refreshing/ calculating. Not entirely sure. 

 

I don't know your exact case but that's what I did for mine without having to lose the ENTIRE report I had just created. 

 

Let me know if this helps! 🙂 

~heathernicoale

Aha great!

 

I thought I had lost 2 months of report generation!

 

In my case, I had created a new column in the database, using modelling, and used that new column to create a visual. Somehow during my 'manipulation' of the visual I managed to get into an infinite loop of errors!

 

To fix my issue I followed your lead > but instead I copied the new column's DAX to my clipboard > deleted the column > saved as a new file (just to be safe) > re-opened it > and got a 'you fool, you've broken your visual!" type error message but now I was able to delete it!

 

Everything back to normal and no lost report!

 

Thankyou Thankyou Thankyou!

For anyone else that finds this thread - I have just had exactly the same error again...
It happened last time whilst working with the new trend lines feature in visuals - and has happened again whilst working with trend lines again!
Is there a trend (pardon the pun)?

 

 

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

November Power BI Update 768x460.png

Check it Out!

Click here to read more about the November 2021 Updates!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.