cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Unable to unclick include other group

I am not sure why this is happening. 

I made two groups of values between 5-10, and 11- above, and I want to display these two groups with ungrouped values 0-4. 

I am not able to unselect the "Include Other group"

There is a message also popping with (i) next to the  click section in the bottom right that takes me to this link about grouping. 

https://powerbi.microsoft.com/en-us/documentation/powerbi-desktop-grouping-and-binning/

 

Please help!! (IMage below)

unable to uncheck the include other groupunable to uncheck the include other group

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Microsoft
Microsoft

Re: Unable to unclick include other group

@ngupta,

It is not possible to unselect include other group when creating groups for numerical fields. Please change the data type of your field to Text, then you are able to unselect include other group when creating groups for the field.
1.JPG

Regards,
Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

6 REPLIES 6
Highlighted
Microsoft
Microsoft

Re: Unable to unclick include other group

@ngupta,

It is not possible to unselect include other group when creating groups for numerical fields. Please change the data type of your field to Text, then you are able to unselect include other group when creating groups for the field.
1.JPG

Regards,
Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Highlighted
Frequent Visitor

Re: Unable to unclick include other group

Thanks Lydia, 

This works, I changed the format to text and now I can group and see non-grouped items too. 

 

One additional follow up question:

For a stacked bar chart, the group always takes the lowest place on the graph. I want the group to be on the top. For eg: my data has no. of bids for procurement and there are some with 2, 3, 4 and 5+(5-15) bids. I want to present with 5+ bids group to be on the top and followed by a descending order or 4,3,2. but I am getting the following order from top to bottom= 4, 3, 2, 5+. (see below)

grouping approach.JPG

 

I tried creating separate column and to sort by that column, i have bids from 5-15 range, and even if I create a column (for sorting ), to capture as many in the range, still the blank/uncaptured data is at the bottom. I don't want to write if command for all possible number of bids. Any suggestions.

new column approach.JPG

Highlighted
Microsoft
Microsoft

Re: Unable to unclick include other group

@ngupta,

Would you mind sharing me the PBIX file so that I can test? You can post PBIX file to OneDrive and post shared link of the file via Private Message. Do mask sensitive data before uploading PBIX file.

Regards,
Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Frequent Visitor

Re: Unable to unclick include other group

Sorry about the delay, I will share the file in the next few days. Dealing with some data privacy issues.

Highlighted
New Member

Re: Unable to unclick include other group

Hi,

I have my column as text data type, yet I still can't untick it. Any tips?

Highlighted
Frequent Visitor

Re: Unable to unclick include other group


@ngupta wrote:

Thanks Lydia, 

This works, I changed the format to text and now I can group and see non-grouped items too. 

 

One additional follow up question:

For a stacked bar chart, the group always takes the lowest place on the graph. I want the group to be on the top. For eg: my data has no. of bids for procurement and there are some with 2, 3, 4 and 5+(5-15) bids. I want to present with 5+ bids group to be on the top and followed by a descending order or 4,3,2. but I am getting the following order from top to bottom= 4, 3, 2, 5+. (see below)

grouping approach.JPG

 

I tried creating separate column and to sort by that column, i have bids from 5-15 range, and even if I create a column (for sorting ), to capture as many in the range, still the blank/uncaptured data is at the bottom. I don't want to write if command for all possible number of bids. Any suggestions.

new column approach.JPG


Because you changed the field to be text the sorting works different.

 

For numbers it is 1, 2, 3 … 10, 11 etc. For text it will be 1, 10, 2, 20 3, 30.

To make this more clear AB will come before C even when C has less characters. This is the same why 10 comes before 2.

 

So to solve this edit the title of the group to start with an index "1) 10 & 11 & 12 & …"

Helpful resources

Announcements

August Community Highlights

Check out a full recap of the month!

Experience what’s next for Power BI

Join us for an in-depth look at the new Power BI features and capabilities at the free Microsoft Business Applications Launch Event.

Top Solution Authors