cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
wicker4
Regular Visitor

Unable to sign in to ArcGIS on Power BI

I am unable to click on the sign in button on the ArcGIS Maps for Power BI visual.  When I add the visual, I get the following.  However, nothing happens when I click on the sign in button.  It looks like the www.arcgis.com address is grayed out.  I was able to sign on a few weeks ago, and all I did was open the visual and click on the sign in button.  Now, I am unable to do so.  I am trying to log in just to the ArcGIS Online and not ArcGIS Enterprise.

 

PowerBI_ArcGIS.png   

 

On the map I created few weeks ago, my log in to ArcGIS must have expired.  I get the following when I click on the profile under ArcGIS for Power BI, but I am unable to click the profile picture or anywhere that allows me to resign on.  I am able to click the learn more button, but that just directs me to find out about ArcGIS products.

 

  Power BI_ArcGISProfile.png

 

Does anyone have any suggestions on how I could sign in to ArcGIS through Power BI?  I can create a map, just by dragging my information.   However, I am trying to create a report that I can later publish and I am unable to publish a report with a map unless I am signed on to ArcGIS through Power BI.

1 ACCEPTED SOLUTION

Hi @wicker4 ,

 

The October version has been released, please check.

https://www.microsoft.com/en-us/download/details.aspx?id=58494 

 

Best Regards,

Jay

Community Support Team _ Jay
If this post helps, then please consider Accept it as the solution
to help the other members find it.

View solution in original post

34 REPLIES 34

So here is an interesting update. By logging into my company account through my personal computer I was able to bypass enterprise software on the computer that might be messing with it and I was able to publish both visuals 3 weeks ago that use Arc for maps. Thought my problem was solved.

 

Fast forward to this morning with an update, and I come to discover while I can still publish one of the visuals, the other one the extension for Arc is blocked. Trying to determine what the difference in the files is that one would work and another would not. Did all the normal caceh clearing recs, but nothing helping so far. If anyone has ideas, I am all ears.

Degnamite
Frequent Visitor

Same issue here

shwetzash
Frequent Visitor

@galmon, if you are talking about having this issue while in powerbi service online- click edit the tab in question and then click on the refresh button - third from the right and save. Unfortunately not all tabs register the credentials by default and therefore the issue. It worked for me for a similar issue I had just yesterday. 

shwetzash_0-1646232009799.png

 

 

I'll give it a try! Its actually not just the online version, but Desktop as well. Whenever I have gotten it to work in the past it is because I fixed it in the desktop version first, and then it gives me no trouble in the online workspace.

Degnamite
Frequent Visitor

Hi galmon,

Same isseu 

shwetzash
Frequent Visitor

I had to do it at both places many a times. Clearing cache once is not enough. In the past three months whenever I had to make changes I had to do the cache delete 3 times already. Deleting cache works, but I also have to go online and do the above sometimes for my embedded link to work for arcgis. @galmon 

Hi shwtzash,

I have tried to delete the cache several times, but with no effect

These 3 steps have worked for me 

1. Clear the folders in the following locations:
o .exe version— %LocalAppData%\Microsoft\Power BI Desktop (for example, <user>\AppData\Local\Microsoft\Power BI Desktop - this folder might not exist for you)
o Microsoft Store version— C:\Users\<user>\Microsoft\Power BI Desktop Store App
2. Delete the folder named CEF.
3. Delete the folder named Cache.

Do not delete cache from the options but from the applocal directory. This is where the issue is. 

I'm having a similar issue with the November 2021 release (Version: 2.99.782.0 64-bit (November 2021)).

 

A white window pops up when I click on the ArcGIS For PowerbI visualisation Sign in button.  A few months back this allowed me to login to my ArcGIS Online Organisation account.  Seems this functionality is not available right now?

 

This is for a new report.  I've tried the suggested solution and did not work for me.

1. Clear the folders in the following locations:
o .exe version— %LocalAppData%\Microsoft\Power BI Desktop (for example, <user>\AppData\Local\Microsoft\Power BI Desktop - this folder might not exist for you)
o Microsoft Store version— C:\Users\<user>\Microsoft\Power BI Desktop Store App
2. Delete the folder named CEF.
3. Delete the folder named Cache.
4. Restart the machine.

Try these solutions above. They worked for me

Thank you for letting me know!  I was able to download the October version.  For some reason, I am  able to log in to ArcGIS on some of my Power BI files and not on other.  However, the fact that I can log in to ArcGIS on any of them is a huge improvement.  Thank you!

Hi @wicker4 ,

 

I downloaded application in the AppStore, it will automatically update. It seems that the web page has not been updated yet. In that case, you may try reinstalling the application and check again.

 

Best Regards,

Jay

Community Support Team _ Jay
If this post helps, then please consider Accept it as the solution
to help the other members find it.
v-jayw-msft
Community Support
Community Support

Hi @wicker4 ,

 

What version you are using? I'm using Version: 2.98.542.0 64-bit (October 2021) and the login page will pop up when the sign in button is clicked.

 

Best Regards,

Jay

Community Support Team _ Jay
If this post helps, then please consider Accept it as the solution
to help the other members find it.

Hi Jay, 

 

I am still having issues after uninstalling all powerbi desktop iteration and redownloading the most recent October 2021 version (2.98.683.0). I click sign in on the PowerBi Mapvisual and nothing happens. I also have other maps created where I can select "Connect to ArcGIS" and nothing happens when I click that button (typically it launched the ArcGIS log-in screened and I logged in just fine. It has previously worked with the new PowerBI symbology and all of my layers from the ArcGIS Online portal / My Content. Some days it works other days it does not. I have cleared my PowerBi Desktop's cache as well as my default web browser's cache (Google Chrome).  

 

Thank you for any help or assistance in this matter. 

Helpful resources

Announcements
Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

charticulator_carousel_with_text (1).png

Charticulator Design Challenge

Put your data visualization and design skills to the test! This exciting challenge is happening now through May 31st!

May UG Leader Call Carousel 768x460.png

What difference can a User Group make for you?

At the monthly call, connect with other leaders and find out how community makes your experience even better.

Power BI Release May 2022 768x460.png

Check it out!

Click here to read more about the May 2022 updates!