cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
BiMark
Frequent Visitor

Unable to iFrame PBI Reports in PBIRS

Suddenly all of our embeded reports have stopped working, throwing a CSO error.

 

We are on January 2020 of PBIRS and using the embed code provided by microsoft

 

<iframe width="1700" height="1000" src="https://report server/reportname here?rs:embed=true" frameborder="0" allowfullscreen="true"></iframe> 

 

Refused to display 'https://rsserver/report?rs:embed=true' in a frame because it set 'X-Frame-Options' to 'sameorigin'.

1 ACCEPTED SOLUTION
BiMark
Frequent Visitor

@v-yuta-msft I was able to resolve it, i hope others can benefit from my resolution

 

In the Report server advanced settings, the custom header defaults to SAMEORIGIN after the January 2020 update.

 

In our case, our server is only internal, so we replaced it with a wildcard

E.G.

<CustomHeaders> <Header> <Name>X-Frame-Options</Name> <Pattern>(.+)((\/api)|(\/(mobilereport|report|powerbi|excel|pages)\/(.+)(rs:embed=true|rc:toolbar=false)))</Pattern> <Value>*</Value> </Header> </CustomHeaders>

View solution in original post

8 REPLIES 8
BiMark
Frequent Visitor

@v-yuta-msft I was able to resolve it, i hope others can benefit from my resolution

 

In the Report server advanced settings, the custom header defaults to SAMEORIGIN after the January 2020 update.

 

In our case, our server is only internal, so we replaced it with a wildcard

E.G.

<CustomHeaders> <Header> <Name>X-Frame-Options</Name> <Pattern>(.+)((\/api)|(\/(mobilereport|report|powerbi|excel|pages)\/(.+)(rs:embed=true|rc:toolbar=false)))</Pattern> <Value>*</Value> </Header> </CustomHeaders>

View solution in original post

Hello,

I'm having the same problem.

Could you please better explain your solution?

I cannot find the settings for custom header

Thank yoy in advcance

Regards

(1) Use SSMS

When it prompt for selection fill the following:

Example: 

-Server Type: Reporting Service

-Server Name: Http://xyzserver/ReportServer

-Windows Authentication

-Connect

(2) You will be connected to your Report Server Instance

(3) On the left pane under Object Explorer right click on the Report Server - Properties

(4) Last Option Advanced 

(5) CustomHeaders

<Value></Value>

I found leaving value as empty worked better instead of wildcard *

 

-Matt 

 

 

The solution provided by @MattArul worked for us. No restart needed.

 

Thanks!

Great!!

Thank you vey much!

Hello BiMark, I have the same problem, I added these CustomHeader lines in rsreportserver.config, and restarted the service through the Report Service Configuration Manager, however the error persists.

 

Could you tell me what I did wrong?

 

Thanks for the help.

could you solve it?

v-yuta-msft
Community Support
Community Support

@BiMark ,

 

This issue should be caused by api side. I would suggest you create a support ticket here.

 

Regards,

Jimmy Tao

Helpful resources

Announcements
2022 Release Wave 1 760x460.png

2022 Release Wave 1 Plan

Power Platform release plan for the 2022 release wave 1 describes all new features releasing from April 2022 through September 2022.

Power BI December 2021 Update_carousel 768x460.jpg

Check it Out!

Click here to read more about the December 2021 Updates!

User Group Leader Meeting January 768x460.png

Calling all User Group Leaders!

Don't miss the User Group Leader meetings on January, 24th & 25th, 2022.

Jan 2022 Dev Camp 768x460 copy.png

Power BI Dev Camp- January 27th, 2022

Mark your calendars and join us for our next Power BI Dev Camp!

Top Solution Authors
Top Kudoed Authors