cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
DatorGator
New Member

Unable to expand columns from SharePoint Online List

Hi,

 

I'm unable to expand columns in an Sharepoint Online List which relate to lookup fields in the original list.  When I click on the expand column icon in the column header I get "LOADING COLUMN NAMES" for an age and then "No columns were found". However, if a record in the unexpanded column is clicked on all the underlysing data is visible along with the column names.

 

Any ideas?

 

 

8 REPLIES 8
Fabio-MLPro
New Member

I'm facing the same problem, when it is a Lookup Column for multiple values I have the same behavior.

 

Untitled.jpg

 

ttinsley
Resolver I
Resolver I

Same issue here.  It seems to happen more consistently when I work against a "People" column on SharePoint

Expand People.png

I don't have the m code for the step as I cannot create the step because it won't go forward.


The connection code is ....

Source = SharePoint.Tables("https://[our account].sharepoint.com/[my site]", [ApiVersion = 15]),
    #"1be...8c0" = Source{[Id="1be...8c0"]}[Items],

 

Anonymous
Not applicable

change ApiVersion = 15 to ApiVersion = 14

exclamation
New Member

I'm having the same issues with managed metadata columns. I see the column containing records, but when I try to expand it to get to the metadata values, I get "no columns were found".

 

When I select a record, I see a table with label, TermGuid, and WssId, but the label is a number not the actual text of the metadata field.

AI
Regular Visitor

I am having the same issue here. Have you had any progress or suggested solutions @exclamation ?

JannikHalling
Regular Visitor

Is it possible for anyone who doesn't face this issue, to copy the M syntax code in the "Advanced Editor"? Maybe it can help to copy and tweak that code, so you don't have to manually select/deselect the column names.

v-sihou-msft
Microsoft
Microsoft

@DatorGator

 

I can't reproduce your issue. When expanding the lookup column, it can load all columns properly (even it takes some time).

 

13.PNG

 

14.PNG

 

Since you can see all underlying data when clicking "Record", those columns should be loaded into this dataset already. It looks like a timeout issue within Query Editor. Please recreate your dataset and try again.

 

Regards,

I also have the same issue, I have PowerBi connected to a sharepoint online list and when trying to expand a column i get hung up on "loading column names"" 

 

I can click on the Record and drill down to see the underlying data. 

 

I have reporduced this on various sharepoint lists / column types. 

 

could it be some kind of authentication issue?

Helpful resources

Announcements
August 2022 update 768x460.jpg

Check it Out!

Click here to learn more about the August 2022 updates!

August 1 episode 9_no_dates 768x460.jpg

The Power BI Community Show

Watch the playback when Priya Sathy and Charles Webb discuss Datamarts! Kelly also shares Power BI Community updates.

Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Top Solution Authors
Top Kudoed Authors