cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jgibbons
Regular Visitor

Unable to connect to Google Analytics

Hello,

We have been encountering difficulties lately connecting to Google Analytics from PBI Desktop. The sign-in process raises a bunch of the infamous "script errors" as it goes through the Google sign-in process, and ultimately drops us into a page requesting that we allow Power BI to access our data, but the "Allow" button can't actually be clicked.

 

Annotation 2021-06-01 231207.png

Annotation 2021-06-01 231344.png

 

All of this is taking place in an embedded browser that opens when you click "sign-in" after selecting the Google Analytics connector from the Get Data dialog.

I am running the very latest available version of Desktop (2.93.981.0) and FWIW recently updated to Win 10 20H2.

I saw the warning on the GA connector documentation saying that as of july we'll need to use the June release of PowerBI due to Google retiring some legacy authentication modes, and I suspect this is related somehow, but the timing seems off.

 

Also, given that PowerBI is now delivered with both WebView2 (Edge/Chromium) and CEF (Chromium) how is it possible that Internet Explorer in whatever shape or form is still being used ?

 

Mysteriously, I was at one point able to access GA while I was debugging this issue: when launching PowerBI from a different user (my admin user), things would work, but as soon as I returned to my normal user it would break again. I played around with my admin user's IE settings and eventually it broke as well, but I have no idea why. I also tried regenerating my own PBI user settings from sratch by renaming my user directory under AppData/Local/Microsoft/Microsoft Power BI Desktop, but to no avail.

 

Any brilliant ideas would be much appreciated.

Thanks,

1 ACCEPTED SOLUTION

I was ultimately able to find a solution, by using the FEATURE_BROWSER_EMULATION registry key to force the embedded IE browser component to emulate IE11, rather than whatever it was behaving as before. Added PBIDesktop.exe with hex value 2af9, cleared the cached credentials in PBID and "voilà", it worked.

See: https://docs.microsoft.com/en-us/previous-versions/windows/internet-explorer/ie-developer/general-in...

 

I'm still not happy that any part of PBID is still leveraging that hopelessly obsolete IE-based webview, but at least my users can work again.

View solution in original post

4 REPLIES 4
v-yangliu-msft
Community Support
Community Support

Hi  @jgibbons  ,

I would suggest to update Power BI Desktop to the latest version, clear all permissions in Data source settings and try logging in again. The same is true for Chrome.

Additionally, Power BI Desktop uses the default IE browser to log in, so you can open your IE browser manually, enter Google Analytics URL and test whether you can log in successfully in the browser.

 

This is a related document, hope it can help you:

https://community.powerbi.com/t5/Desktop/Error-connecting-Google-Analytics-and-Power-Bi/m-p/782185

https://community.powerbi.com/t5/Desktop/Unable-to-connect-to-Google-Analytics/td-p/1779672

https://community.powerbi.com/t5/Desktop/Problem-with-Google-Analytics-data/td-p/965367

https://community.powerbi.com/t5/Desktop/Problem-signing-in-to-Power-BI-script-error/td-p/586231

 

Best Regards,

Liu Yang

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi Liu,

Thanks for the feedback, but I am running the very latest version of PowerBI Desktop. None of the other proposals has worked reliably to date.

But you actually touched on my main point: in 2021, with so many other options (some of which ship with PBID), why is Power BI Desktop still using Internet Explorer for anything at all ? It's no longer a secure or modern browser by any stretch of the imagination, even Microsoft says it.

 

Thanks

I was ultimately able to find a solution, by using the FEATURE_BROWSER_EMULATION registry key to force the embedded IE browser component to emulate IE11, rather than whatever it was behaving as before. Added PBIDesktop.exe with hex value 2af9, cleared the cached credentials in PBID and "voilà", it worked.

See: https://docs.microsoft.com/en-us/previous-versions/windows/internet-explorer/ie-developer/general-in...

 

I'm still not happy that any part of PBID is still leveraging that hopelessly obsolete IE-based webview, but at least my users can work again.

Vams
Frequent Visitor

Hi,

Are you able the fix your issue? 

 

I'm not able to connect to Google Analytics through Power BI Desktop with my organization user account checked in different forum but no luck. Getting error message as follows and by clicking "Sign in", it's showing blank browser but earlier I can see my username. It's the first time getting this type of error. Please provide the solution as this report is in PROD and need to fix ASAP. 

Vams_0-1632983751224.png

 

 

Helpful resources

Announcements
June 2022 update 768X460.jpg

Check it out!

Click here to read more about the June 2022 updates!

Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Power BI Dev Camp Session 23 768x460.jpg

Check it Out!

Mark your calendars and join us on Thursday, June 30 at 11a PDT for a great session with Ted Pattison!

June 20 episode 7 with aka link 768x460.jpg

The Power BI Community Show

Join us on June 20 at 11 am PDT when Kim Manis shares the latest on Azure Synapse analytics, the Microsoft Intelligent Data Platform, and notable Power BI Updates from Microsoft Build 2022.

Top Solution Authors