cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
tcm2007
Advocate I
Advocate I

Unable to alter number formatting

I can't seem to change the format of displayed numbers.

 

The options in the modelling tab are greyed out.

 

Capture.PNG

 

Data is formated as fixed decimal in the query (which is just a CSV load).

 

Any suggestions?

1 ACCEPTED SOLUTION

Figured it out; you have to highlight the field in the Fields selector, not by clciking on the numbers in the report. Not intuitive  to me.

View solution in original post

16 REPLIES 16
Greg_Deckler
Super User IV
Super User IV

You are on the Report tab, try going to the data modeling tab (over on the left just below the column chart icon, the one that looks like a table), select your column and then go to Modeling tab in the ribbon.


---------------------------------------

@ me in replies or I'll lose your thread!!!

I have a NEW book! 
DAX Cookbook from Packt
Over 120 DAX Recipes!




Did I answer your question? Mark my post as a solution!

Proud to be a Super User!




Figured it out; you have to highlight the field in the Fields selector, not by clciking on the numbers in the report. Not intuitive  to me.

View solution in original post

Anonymous
Not applicable

Just starting out to use Power BI, what do you mean by highlighting the Fields Sector?

 

Thanks

Hello,

 

see print.

IonitaA_0-1616495802168.png

 

Thank you , been stuck all morning on this ! 🙄

THank you very much!

Thank You!!!  I've been trying to figure that out for days.

Anonymous
Not applicable

You saved me much time! Thanks!

Could you please tell me more clearly. I don't understand what does 'you have to highlight the field in the Fields selector, not by clciking on the numbers in the report' mean. My Power be like below.

 

Capture.PNG

Hey. 

 

I had the same problem. You need to go to the fields sector on the right and then click the field you would like to change (ex. City) and the modeling section will become available to edit 

Error 1.png

Thanks for the solution

Anonymous
Not applicable

YES!! This really helps!!

Anonymous
Not applicable

The solution you gave here doesn't help me. My "Modeling" is still grey and disabled. 

PS

I'm building my reports based on the Cube, maybe that's the reason of that?

 

Thanks,

I had the same problem. Checking the box in the field selector isn't enough - you have to click onto the measure (as if you were going to edit the formula). Then, the Formatting option should appear available for you.

Anonymous
Not applicable

It will not appear, since I'm using the live connection and all my measures come from the cube. So, basicaly, the solution is o make all the formating at the cube level.

Thanks

skylarw
Frequent Visitor

Thanks! I had the same problem and that fixed it!

Helpful resources

Announcements
MBAS on Demand

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

July 2021 Update 768x460.png

Check it out!

Click here to read more about the July 2021 Updates

Power Query PA Forum 768x460.png

Check it out!

Did you know that you can visit the Power Query Forum in Power BI and now Power Apps

Top Solution Authors
Top Kudoed Authors