cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Unable to Connect to MySQL database

I tried to connect to MySQL database. It gives the following error. Any help please?

 

When I select to SQL

Error Screenshot.JPG

 

Details: "An error happened while reading data from the provider: 'Could not load file or assembly 'Renci.SshNet, Version=2016.1.0.0, Culture=neutral, PublicKeyToken=1cee9f8bde3db106' or one of its dependencies. The system cannot find the file specified.'"

1 ACCEPTED SOLUTION

Solve with previous version of connector.

mysql-connector-net-8.0.16.msi

Thanks !!!

View solution in original post

37 REPLIES 37
Diego-Rivera
Regular Visitor

fixed by uninstalling current connector and installing mysql-connector-net-6.10.7.msi

Anonymous
Not applicable

This is so frustrating. I've spoken to PowerBI support and they couldn't help either. Main points:

 

Trying to connect to MySQL DB secured via SSL

This worked earlier in the year

 

Something changed (no idea what) and now I get an authenticartion error whenever I click login.

 

Things I've tried:

Reinstalling PowerBI

Installing versions 8.0.14, .15. 16 .17 and .18 of MySQL Connector

Using another computer

Adding certs to the computer cert store (Personal, Truster Root, Third party)

Removing everything and starting again

 

To prove it is something to do with the certs I've also asked the DB admin to remove them and this allowed me to connects immediately using username and password only

 

To prove the certs are okay I can connect to the DB from my maching using MySQL workbench. Interestingly you actully point to the cert pem files in the Workbench login screen. I also spoke to Tableau about this and their support were able to help me connect using the same certs with no issues.

 

Please, please, please can someone help. 

Anonymous
Not applicable

Aaah I feel like I'm going a little crazy. So I followed the advice below and donwgraded to an earlier Connector version (8.016 I think) and it cleared this error and I was able to connect fine for a few weeks. I was recently experimenting with another BI tool and needed 8.0.17 so upgraded again. To use PowerBI I downgraded again this week and now whenever I try to connect I just get 'We couldn't authenticate with the credentials provided' message. I've tried 8.0.15, 8.0.16, different user names and passwords and still have the same. Credentials are fine as when I connect via MySQL Workbench it connects okay. Any ideas?

Anonymous
Not applicable

Hi,

 

I solved this problem by uninstalling the latest version of MySQL Connector (8.0.17) and installing the 8.0.15. I followed this video : https://www.youtube.com/watch?v=VC9h7yVRHV8

 

And this is the link to download the version 8.0.15 : https://downloads.mysql.com/archives/c-net/

 

Good luck you all.

Anonymous
Not applicable

Thank you! 8.0.16 fixes my issues as well!

 

I also downloaded it from this link: https://mirrors.dotsrc.org/mysql/Downloads/Connector-Net/

cabc_xlorla
Advocate IV
Advocate IV

YESSSSSS IT WORKED FOR ME !!!!!!

surrender-all.jpg

pascalhoule
New Member

Hello,

 

I have fixed that issue by using an older version fo the mysql-connector...

Here a link that I will share for some time: mysql-connector-net-8.0.12 (x64)

Hope that will help some of you 🙂

 

pH

Anonymous
Not applicable

Thanks) Its working Smiley Happy

Anonymous
Not applicable

I had the same problem, but it emerged from wanting to install the latest version of the Mysql Connector (mysql-connector-net-8.0.17).

 

Once installed, the problem started.

 

I rolled back to the previous version of the connector that I had installed (mysql-connector-net-6.10.8).

 

Problem solved.

trenthord
Advocate I
Advocate I

I had the same problem with 8.0.17. I uninstalled it, and installed 8.0.16 from here: https://mirrors.dotsrc.org/mysql/Downloads/Connector-Net/ . Error went away. 

Hi,

Am using the sqlconnector 8.0.16 but still am facing the same error , could you please help ASAP.

 

Regards,

Suresh .

Hi @SureshPantra, as everyone has been starting throughout the thread, please install 8.0.15 !
I have just done it 2 minutes ago and it has worked for me.
Anonymous
Not applicable

Perfect. This worked for me too.

Can confirm, it doesn't work with 8.0.17 but does work with 8.0.16: https://mirrors.dotsrc.org/mysql/Downloads/Connector-Net/mysql-connector-net-8.0.16.msi (tested with PBIRS-January version, if that matters).

Solve with previous version of connector.

mysql-connector-net-8.0.16.msi

Thanks !!!

I had a different error "call to SSPI failed". Installing version 8.0.16 of connector also solved my problem. Current version today is 8.0.28. Also, restarted my computer after reinstalling.

Anonymous
Not applicable

Hi,

 

i have downloaded and installed 8.0.16, but still it shows 8.0.17 in start menu.

 

How do i check whether it is 8.0.16 in MySQL?

 

i belive folder name is 8.0.17 but it has changed.

 

please let me know if you have any suggestion or solution for it.

Hi Nagesh,

Try uninstalling all MySQL components (if you don´t you use MySQL), then just install that connector and give it another try. It should work. I recently swipe my hard drive with a Solid States and did the same process the it worked. Please let me know how it goes. Also I can help you thru Teamviewer.

Anonymous
Not applicable

Hi

 

Should i uninstall entir MYSQL and reinstall it again, if so can you give me the link of 8.0.16.

 

If i install that, will i automatically get MYSQL Workbench?

 

Thanks in advance:)

Helpful resources

Announcements
June 2022 update 768X460.jpg

Check it out!

Click here to read more about the June 2022 updates!

Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Power BI Dev Camp Session 23 768x460.jpg

Check it Out!

Mark your calendars and join us on Thursday, June 30 at 11a PDT for a great session with Ted Pattison!

June 20 episode 7 with aka link 768x460.jpg

The Power BI Community Show

Join us on June 20 at 11 am PDT when Kim Manis shares the latest on Azure Synapse analytics, the Microsoft Intelligent Data Platform, and notable Power BI Updates from Microsoft Build 2022.

Top Solution Authors
Top Kudoed Authors