cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
pwanjerkhede
Frequent Visitor

Unable to Connect Power BI to Impala connector

Hi PBI Community,

I am facing the below error message while connecting to Impala Connector. 

 

Unable to Connect

We encountered an error while trying to connect.

Details: "ODBC: ERROR [HY000] [Microsoft][DriverSupport] (1100) SSL certificate verification failed because the certificate is missing or incorrect."

 

Any solution/workaround is appreciated.

 

Thanks,

Pratap

1 ACCEPTED SOLUTION

I worked with Microsoft and found a workaround!

 

You would need to create the microsoft.impalaodbc.ini file inside the path as shown below

  • for PowerBI Desktop: C:\Program Files\Microsoft Power BI Desktop\bin\ODBC Drivers\<Simba Driver Name>
  • For On-premise data gateway: C:\Program Files\On-premises data gateway\ODBC Drivers\<Simba Driver Name>

You will need to put the following 3 lines in the file:

[Driver]

AllowHostNameCNMismatch = 0
CheckCertRevocation = 0

 

my ini file looks like below snapshot and it works:

After you have created the file above in that path, close and restart Power BI Desktop if it was running.

View solution in original post

4 REPLIES 4
v-lili6-msft
Community Support
Community Support

hi, @pwanjerkhede 

What version of Power BI Desktop do you use? Please update your Power BI Desktop to latest version(2.73.5586.661 64-bit (September 2019) ).

In addition, do you configure SSL for the Impala server? If so, ensure that the SSL protocol version is lower than TLS 1.2.

and also try refer to this blog:

SSL Security Error with Data Source

Regards,

Lin

Community Support Team _ Lin
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

@v-lili6-msft  Thank you for your inputs.

 

I am using the latest version: 2.73.5586.561 64-bit (September 2019).

I am not sure about configuring SSL for the Impala server. 

 

I am able to connect to Impala through ODBC connection in  Power BI but not through the Power BI built-in Impala connector.

ODBC  configuration is successful. But the Built in Impala connector is giving throwing below error:

 

Details: "ODBC: ERROR [HY000] [Microsoft][DriverSupport] (1100) SSL certificate verification failed because the certificate is missing or incorrect."

 

ODBC.PNG

 

Thanks,

Pratap

 

Here is the error snapshot using impala connector

SSL.PNG

I worked with Microsoft and found a workaround!

 

You would need to create the microsoft.impalaodbc.ini file inside the path as shown below

  • for PowerBI Desktop: C:\Program Files\Microsoft Power BI Desktop\bin\ODBC Drivers\<Simba Driver Name>
  • For On-premise data gateway: C:\Program Files\On-premises data gateway\ODBC Drivers\<Simba Driver Name>

You will need to put the following 3 lines in the file:

[Driver]

AllowHostNameCNMismatch = 0
CheckCertRevocation = 0

 

my ini file looks like below snapshot and it works:

After you have created the file above in that path, close and restart Power BI Desktop if it was running.

View solution in original post

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

November Power BI Update 768x460.png

Check it Out!

Click here to read more about the November 2021 Updates!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.