cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
New Member

Type mismatch: Unable to convert a value to the data type requested (Gateway Error)

we have NPI column has contains below like data number's and names. i fixed the npi column data type as a text. when i'm refreshing in gateway showing the below type mismatch error. We need both NPI names & Id's. can you please guide me how to resolve this error

rveerasamy1_0-1602308613384.png

 

 

 

Processing error: The following system error occurred: Type mismatch. Unable to convert a value to the data type requested for table 'Surgeon Sales' column 'NPI'. The data provider was unable to convert the value 'Kevin Boyer' from the source data type 'VT_BSTR' to the expected data type 'VT_I8'. Please check the column data types in the data model and data source and ensure that the data types are compatible. Cluster URI: WABI-US-EAST2-redirect.analysis.windows.net Activity ID: 7130e1e3-a46b-4e32-9ba4-e1168fab10b7 Request ID: 95d8cb13-5378-eaae-723f-45831cc86d57 Time: 2020-10-08 13:23:06Z

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support
Community Support

Hi @rveerasamy1 ,

 

You may enter into Query Editor in Power BI Desktop, go to APPLIED STEPS, find the step named "Changed type" , delete this step.

 

Or you may go to File -> Options and settings -> Options ->CURRENT FILE ->Data Load, don't tick the option "Detect column types and headers for unstructured sources", restart the Power BI Desktop to take effect of this change.

 

Detect Type 2.png

Best Regards,

Amy 

 

Community Support Team _ Amy

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

2 REPLIES 2
Solution Sage
Solution Sage

Community Support
Community Support

Hi @rveerasamy1 ,

 

You may enter into Query Editor in Power BI Desktop, go to APPLIED STEPS, find the step named "Changed type" , delete this step.

 

Or you may go to File -> Options and settings -> Options ->CURRENT FILE ->Data Load, don't tick the option "Detect column types and headers for unstructured sources", restart the Power BI Desktop to take effect of this change.

 

Detect Type 2.png

Best Regards,

Amy 

 

Community Support Team _ Amy

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helpful resources

Announcements
November Update

Check it Out!

Click here to read more about the November 2020 Updates!

Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

secondImage

Power Platform October Community Highlights

Check out the top community contributors across all of the communities

secondImage

Create an end-to-end data and analytics solution

Learn how Power BI works with the latest Azure data and analytics innovations at the digital event with Microsoft CEO Satya Nadella.

Top Solution Authors
Top Kudoed Authors