cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
molegris
Advocate II
Advocate II

True/False DAX filter not working

Hi,

 

I converted my formula to output 0/1 and it works.  I can use it as a workaround but I still wonder if anybody knows why the True/False version is not working.  It is a Power BI limitation (bug?)

 

When the formula returns true/false it's not even possible to open the filter to set it up.  I tried deleting and reinserting many times and it never works.  (See image-1)  But by changing it to 1/0 it behaves perfectly.  (See image-2)

 

molegris_0-1609790317824.png

 

molegris_1-1609790331735.png

 

Thank you

--mo

1 ACCEPTED SOLUTION
Fowmy
Super User
Super User

@molegris 

Yes, There TRUE/FALSE are not accepted, you need have either 1 or 0.

________________________

If my answer was helpful, please click Accept it as the solution to help other members find it useful

Click on the Thumbs-Up icon if you like this reply 🙂


Website YouTube  LinkedIn

Did I answer your question? Mark my post as a solution! and hit thumbs up


Subscribe and learn Power BI from these videos

Website LinkedIn PBI User Group

View solution in original post

4 REPLIES 4
parry2k
Super User
Super User

@molegris why not do this, change the last line to the following code:

 

__maxSessions = __globalMaxSessions

 

Check my latest blog post Year-2020, Pandemic, Power BI and Beyond to get a summary of my favourite Power BI feature releases in 2020

I would  Kudos if my solution helped. 👉 If you can spend time posting the question, you can also make efforts to give Kudos to whoever helped to solve your problem. It is a token of appreciation!

Visit us at https://perytus.com, your one-stop-shop for Power BI-related projects/training/consultancy.

 






Did I answer your question? Mark my post as a solution.

Proud to be a Super User! Appreciate your Kudos 🙂
Feel free to email me with any of your BI needs.





Thank you but I've tried this too.  Same behavior: you can see the filter but it is impossible to set it.

According to @Fowmy  it is a known behavior.  I'm just hope Microsoft will eventually fix it!

 

molegris_0-1609792679563.png

 

Fowmy
Super User
Super User

@molegris 

Yes, There TRUE/FALSE are not accepted, you need have either 1 or 0.

________________________

If my answer was helpful, please click Accept it as the solution to help other members find it useful

Click on the Thumbs-Up icon if you like this reply 🙂


Website YouTube  LinkedIn

Did I answer your question? Mark my post as a solution! and hit thumbs up


Subscribe and learn Power BI from these videos

Website LinkedIn PBI User Group

Thank you for comfirming it. 

Do you know if Microsoft has documented it anywhere?  Do they consider this to be Working as documented or is it an Issue/Bug to be resolved ?

Helpful resources

Announcements
November 2022 Update

Check it Out!

Click here to read more about the November 2022 updates!

Microsoft 365 Conference â__ December 6-8, 2022

Microsoft 365 Conference - 06-08 December

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Power BI Dev Camp Session 27

Ted's Dev Camp

This session walks through creating a new Azure AD B2C tenant and configuring it with user flows and custom policies.