cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Fragan
Helper III
Helper III

Troubleshooting visual performance

Hey,

 

I have some visual with high loading time.

 

The visuals Data are calculated using DAX.

 

When using the performance analyser the Dax Requests loading time looks fine (around 150ms overall) but the "Others" loading time is too high (around 5000ms overall), what may be the problem ?

 

image.png

 

Regards.

1 ACCEPTED SOLUTION
speedramps
Impactful Individual
Impactful Individual

Please consider some of these solutions ....

 

Try use 7 of less visuals on a page. The more visuals you use, the slower a page will be.

 

Test each visual separately on an empty page with the performnace analyser, if one of them is especially long then try imporve it or avoid sharing it on pages with other visuals if you know it will delay the whole page. 

 

Try reorder the visuals in the selection window. This might triger the visuals to execute in that order ???

 

See https://www.sqlgene.com/2019/09/27/a-comprehensive-guide-to-power-bi-performance-tuning/

View solution in original post

3 REPLIES 3
speedramps
Impactful Individual
Impactful Individual

Hi Fragan

 

Please consider this solution ....

 

Copy the visual to an empty page and try the performance analyser again.

 

The reason I suggest this is because I gather high "Other" can be caused by waiting time for other visuals.

 

If the "Other" is still high, then try post an example for the techy community to see.

 

Oh yeah you're right.

 

Is there any solution to make the visuals not wait for each others?

speedramps
Impactful Individual
Impactful Individual

Please consider some of these solutions ....

 

Try use 7 of less visuals on a page. The more visuals you use, the slower a page will be.

 

Test each visual separately on an empty page with the performnace analyser, if one of them is especially long then try imporve it or avoid sharing it on pages with other visuals if you know it will delay the whole page. 

 

Try reorder the visuals in the selection window. This might triger the visuals to execute in that order ???

 

See https://www.sqlgene.com/2019/09/27/a-comprehensive-guide-to-power-bi-performance-tuning/

View solution in original post

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Power BI October Update 2021.jpg

Power BI Release

Click here to read more about the October 2021 Release!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Teds Dev Camp Oct. 2021 768x460.jpg

Power BI Dev Camp - October 28th, 2021

Mark your calendars and join us for our next Power BI Dev Camp!