cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Cj
New Member

The parameter is expected to be of type Text.Type or Binary.Type.

Hi, 

for the last two days I've having problems with one of our connections.  We get an "error occurred while processing the data in the dataset."

 

The details of the error says "The parameter is expected to be of type Text.Type or Binary.Type."

 

Does anyone know what's wrong and what to do to solve the problem?

7 REPLIES 7
stunuguntla
Frequent Visitor

I had the same issue, so i tried to recreate the file from the begining and compared the M query and steps in the new file and file with error. 

The scenario I was is of source is type of "Folder" and when I went to Transform Data/ Edit Queries window, I double clicked on the File which was shown in queries section named as  "Sample file" this created additional steps and corrupted the next parameter step.

 

So I would suggest make sure the parameter is working and it has pointing to the right column.

When you click on "Sample File" in Queries section it should have only two applied steps Source and Navigation.

attached screenshot might give you a reference 

Hope this would help some one

 

powerBI.png 

 

I know this is late :), but I just experienced this and thought I'd explain what happened in my case.  I was tweaking a package to create dynamic, parameter driven folder paths for the Folder Connector.  Finally got all of the parts working, Individual file queries were accepting the new paths, but the "Transform Sample File" was throwing the error mentioned by the OP.  In my case, the error looked like this:

2021-04-05_6-33-47.jpg

 

The file had somehow lost attributes of the Sample File Parameter.  Note the Suggested and Default values are incorrect:

dwainew_0-1617631069241.pngdwainew_1-1617631121201.png

 

The only required change was to reset the Suggested Values to Binary and the Default and Current values to the "Sample File".

dwainew_2-1617631234444.png

 

gev432
Regular Visitor

I don't know if this will help anyone two years later, but I also encountered this error and was able to fix it.

 

For me the error came from some html that I was parsing using the 'parse xml' command from the toolbar. There were some nulls in my dataset which generated the error when the parsing was attempted. My work around was to replace the null values with an empty structure "<div></div>" which was then parsed and returned a null value correctly

drewlewis15
Solution Specialist
Solution Specialist

Which step is producing this error?  Are you connecting to a folder?

Facing the same issue, how can this be fixed?

 

apoorva
New Member

Can Anyone Please Help for the Error

Anaplex
Frequent Visitor

I recently rebuilt my pc and now I am getting this issue "The parameter is expected to be of type Text.Type or Binary.Type." on refresh which previously worked fine for months.

 

The error occurs after I have merged to existing tables (they have no errors) and I try to expand out the columns.

 

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Power BI October Update 2021.jpg

Power BI Release

Click here to read more about the October 2021 Release!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Teds Dev Camp Oct. 2021 768x460.jpg

Power BI Dev Camp - October 28th, 2021

Mark your calendars and join us for our next Power BI Dev Camp!