cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Johalien
Frequent Visitor

The column " of the table wasn't found

Hi

 

My source data is from a google sheet. It has not changed in any way - I have been working on it for the last month.

However, suddenly I am getting errors.

 

Today I re-imported the source and noted that as soon as I remove columns I get the following error:

 

"The column of the table wasn't found"

 

It does not matter which column I remove. I will continue to get that error until I added all removed columns back.

 

Yes, I updated gateway. Yes, I checked the advanced editor. Yes, I checked the types. No, I did not add any customer columns. The ONLY thing causing this error is when I remove a column. I even made sure to make not changes except removing columns (Applied steps shows Source / Navigation / Removed Columns. Am I missing a hidden setting that I might have accidentally activated?

 

Johalien

1 ACCEPTED SOLUTION

4 REPLIES 4
agarcia0421
New Member

I tried the above and it was not my issue. My issue was i load a weekly excel report and the report was actually missing a column of which had no impact to my dashboard but created a block and failed to load Power BI on the reffresh data. I went to Power uery Editor and then advancd edritor and modified the query by remvoing the missing column in quesiton and all worked and refreshed my dashboard after saving. 

olorin
New Member

I have an alternative solution to the same issue  (different reason) that might help some users (especially beginners and non-coders). I was having the same issue because somewhere upstream my dataset changed a column header from "REPORT_TYPE" to "Report_type" which was breaking my refresh. Initially, I tried automating a column name change, but tht still didn't work (I didn't want to simply change my source because I would have had to rebuild parts of my dashboard). Finally, I went into "Edit Queries" and used the "Advanced Editor" to find a reference to the all caps version of my header, manually edited the querie, saved and refreshed... just like magic! 

v-yuta-msft
Community Support
Community Support

Hi Johalien,

 

Are you using custom connectors to connect to google sheet? For troubleshooting, please check if everything is OK if you just delete some values in google sheet.

 

Regards,

Jimmy Tao

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

November Power BI Update 768x460.png

Check it Out!

Click here to read more about the November 2021 Updates!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.