cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
belvoir Member
Member

Table visual automatically summarizing - how do i avoid it?

Hi there,

 

My table visual is automatically summarizing the data when the whole row matches. I have clicked Don't summarize on all the columns. The only way I seem to be able to get it to show all the rows in the table is to add an Index column in Power Query and then drag it onto the table visual, treating it as a primary key in effect.

 

I have had this problem before and feel there is something obvious I need to do, but I can't remember!

 

Thanks.

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support Team
Community Support Team

Re: Table visual automatically summarizing - how do i avoid it?

hi, @belvoir 

Since the visual result needs to be summarized, so it will automatically summarizing.

And for the fields you don't want to summarize, you could set it Default Summarization: Don't summarize

3.JPG

Or as you said, add an Index column in Power Query and then drag it onto the table visual, treating it as a primary key in effect, then decrease the size of the columns until they are hidden. Like in excel in the middle of two colums you can resize them. Be aware that you first need to turn off word wrap.

 

Best Regards,

Lin

 

 

Community Support Team _ Lin
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

2 REPLIES 2
Community Support Team
Community Support Team

Re: Table visual automatically summarizing - how do i avoid it?

hi, @belvoir 

Since the visual result needs to be summarized, so it will automatically summarizing.

And for the fields you don't want to summarize, you could set it Default Summarization: Don't summarize

3.JPG

Or as you said, add an Index column in Power Query and then drag it onto the table visual, treating it as a primary key in effect, then decrease the size of the columns until they are hidden. Like in excel in the middle of two colums you can resize them. Be aware that you first need to turn off word wrap.

 

Best Regards,

Lin

 

 

Community Support Team _ Lin
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Highlighted
belvoir Member
Member

Re: Table visual automatically summarizing - how do i avoid it?

Hi @v-lili6-msft 

 

Yes, thanks. I've already turned off the Summarization settings and it doesn't affect the result. So the Index approach is the workaround.

 

At least I know now that it is a strange aspect of the Table visual. Do you know why it is designed this way? 

 

See ideas - https://ideas.powerbi.com/forums/265200-power-bi-ideas/suggestions/35242144-show-all-data-in-table-v...

Helpful resources

Announcements
Ask Amanda Anything Q&A

Ask Amanda Anything Q&A

Learn the answers to some of the questions asked during the Amanda Triple A event.

October 2019 Community Highlights

October 2019 Community Highlights

October was a busy month in the community. Read the recap article to learn about some of the events and content.

New Solution Badges

New Solution Badges

Two waves of brand new solution badges are coming! Read the article for more information on our new community badges.

Analytics in Azure virtual event

Analytics in Azure virtual event

Experience a limitless analytics service built to ingest, prep, manage, and serve data for immediate use in Power BI.

Users Online
Currently online: 125 members 1,447 guests
Please welcome our newest community members: