cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
sanoraya
Frequent Visitor

Sorting the Slicer

Hi, 

I am struggling with how to sort the slilcer the way I need: 

 

I have a table like this: 

Number Month

1           Jan

2           Feb. 

3           March

etc... 

 

The slicer only allows sorting alphabetically, but I want the months in the Slicere to be sorted by their Number. I know now the Slicer suprisingly doesn't allow to sort by another column in the table. So what are my options? 

I followed this recommerndation https://powerbi.microsoft.com/en-us/documentation/powerbi-desktop-sort-by-column/ and  sorted by the Number in the QueryEditor, but it has no effect on how the Months are displayed. Am I doing somehtign wrong, or is it Slicer's specific?

 

Thanks a lot!

 

 

 

 

 

2 ACCEPTED SOLUTIONS
GilesWalker
Skilled Sharer
Skilled Sharer

@sanoraya - To order your months by a number range I go to the data tab in Power BI desktop:

 

Data tab.PNG

 

In the ribbon you will see the Sort By Column button. Select the column you are interested in first (in my picture it would be Months), then click the Sort By Columns button.

 

Now you need to have a column which lists the months in the numeric order you want. For example, January will always show up as 1. In the sort by column button you will then need to click the appropriate column containing the month numbers.

 

This will then sort your slicer the way you want.

 

Thanks,

 

Giles

View solution in original post

Anonymous
Not applicable

Hi @sanoraya,

 

   try following my post here.

Let me know if it works.

 

#I'M Not An Expert#

View solution in original post

18 REPLIES 18
bjorba
Regular Visitor

Aren't helped of suggested solution due to I have my data on months level and then want to use a calendar table on month level instead of date level.

 

There are another Slicer called "HierarchySlicer" that solves it by having a non visible Value field that are possible to sort on. Another good future with that are that you can use multible columns in an Hierarchy of what you want to filter.  Something that should be included by the standard microsoft slicer!!

 

bjorba, you made my day, thanks

Tcook
Advocate II
Advocate II

The solution is far easier than I thought. 

 

Steps

  1. In the "Fields" pane, click on the field that is being dispalyed.
  2. On the "Modeling" tab, click "Sort By Column".
  3. Chose the column that you want to sort the displayed field by.
  4. Viola

This option no longer exists on my Modeling tab. Has it been moved?

The option is right there as usual:

In this example, I sorted my reports for the Superintendent Column, which is sorted by the Order Column so, is not get sorted alphabetically but by the numbers set in the Order Column

 

jmcl70_0-1666204857521.png

 

Ahh I see what I did wrong. I was clicking on the field within the hierarchy, instead of the calculated column itself. I found it, thanks!

Anonymous
Not applicable

Thanks Tcook !!! From all posts I've read, this is the only way it's working. And yes it is so simple...

Vola! Esta es la solucion, muchas gracias

Anonymous
Not applicable

Hi @sanoraya,

 

   try following my post here.

Let me know if it works.

 

#I'M Not An Expert#

Thank you very much!

GilesWalker
Skilled Sharer
Skilled Sharer

@sanoraya - To order your months by a number range I go to the data tab in Power BI desktop:

 

Data tab.PNG

 

In the ribbon you will see the Sort By Column button. Select the column you are interested in first (in my picture it would be Months), then click the Sort By Columns button.

 

Now you need to have a column which lists the months in the numeric order you want. For example, January will always show up as 1. In the sort by column button you will then need to click the appropriate column containing the month numbers.

 

This will then sort your slicer the way you want.

 

Thanks,

 

Giles

Ah, so you select the column that you want to show on your slicer (e.g. Month name), then you click on 'Sort By Column' and sort by the month number column.

Thank you!

I cannot see this working.

 

My report seems completely agnostic to sort order in the tables view. The control only gives me option of sorting in the order of the field itself 😞

 

EDIT: Hey Presto! I got it to work. It is crucial to understand that sort order is specified separately on each column, and not on the table as a whole. In the typical scenario, where one wants the slicer sorted according to values in another column, the relevant sort order must be specified on the column holding the display values of the slicer.

BobCoe
Frequent Visitor

Thank you!!  I wasn't getting it to work until I saw your edit!  

Nice one @Dag. That's the key 🙂 

Is there a way to sort in descending order? I have 3 columns and ID, Name, and Count. I want to sort by the largest count first.

Hi, I did that but didn't work for me 😞 

 

I have a weekdays slicer and tried the same..I created a column of week days numbers and sorted by it ....it did sort the table but nothing changed on the report page the slicer is sorted alphabetically 

 Help Please !!!!!

Werafa
Regular Visitor

Me too.

 

want calendar sorted by fin year.

Slicer is randomly sorted, and does not respond to sorting the source data table

Helpful resources

Announcements
November 2022 Update

Check it Out!

Click here to read more about the November 2022 updates!

Microsoft 365 Conference â__ December 6-8, 2022

Microsoft 365 Conference - 06-08 December

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.