cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
iron_dinges
Helper II
Helper II

Slicer item cut off horizontally and not loading all values

I have a strange issue with a slicer in a particular report.

Please see screenshot below:

iron_dinges_0-1615968560040.png

 

The last item in the list has been cut in half horizontally. It is not possible to click below the cut off line.

In this particular slicer, there is actually another item that should be visible below this cut off one. That item is not shown at all.

 

When I create a normal slicer (that is, not a drop down) using this same column, it has exactly the same issue.

 

What does fix it is when I use the filter pane to filter out the top value - the blank text.

 

I can work around this by manually replacing that blank value with a text value saying "blank" or something, but this is such a strange issue, what could be causing this?

5 REPLIES 5
amitchandak
Super User
Super User

@iron_dinges , I have seen cut values only when there is scroll. If there is scroll you can do a bit resize and adjust. If not is there any other visual overlapping this ?

Did I answer your question? Mark my post as a solution! Appreciate your Kudos!! !!
Dashboard of My Blogs !! Connect on Linkedin

Learn Power BI Beginners !! Advance Power BI Concepts !! Power BI For Tableau User !! Learn Power BI in Hindi !!
Proud to be a Super User!

@amitchandak This is not due to scroll.

As you can see in my example, there is still ample space below the cut off value for the scroll bar.

When I change it to a non-dropdown slicer and reduce the size to get the scroll bar, this item is still cut off and the one below is still missing.

 

There are no overlapping visuals.

 

After replacing the "" value with "blank" in my SQL query, it is working fine, so I'm wondering if there is perhaps some funky character in the blank value that is causing this?

 

Another factor is that this report is using DirectQuery, I have not tested if the same issue occurs on Import mode.

I've been able to replicate the issue by bring just that column into a new report.

I made two copies of the data source, one import and one direct query.

The import version works normally.

The direct query version exhibits the same cutoff behaviour described above.

 

Strangely, when resizing the visuals the issue comes and goes.

 

I have two visuals:

A - direct query slicer

B - direct query slicer

 

A shows the cutoff behaviour. Visual size is the default.

B is made as a copy of A.

 

When I resize B to the full height of the report page, all values are showing.

A is now also showing all values.

Resizing B to a smaller size shows the issue again.

Resizing B to a larger size again resolves the issue.

It does not always happen at the same size, it is very inconsistent.

@iron_dinges , I think you should log an issue with screenshot - https://community.powerbi.com/t5/Issues/idb-p/Issues

Did I answer your question? Mark my post as a solution! Appreciate your Kudos!! !!
Dashboard of My Blogs !! Connect on Linkedin

Learn Power BI Beginners !! Advance Power BI Concepts !! Power BI For Tableau User !! Learn Power BI in Hindi !!
Proud to be a Super User!

@iron_dinges , I tested on import, but I do not have blanks. 

Did I answer your question? Mark my post as a solution! Appreciate your Kudos!! !!
Dashboard of My Blogs !! Connect on Linkedin

Learn Power BI Beginners !! Advance Power BI Concepts !! Power BI For Tableau User !! Learn Power BI in Hindi !!
Proud to be a Super User!

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

November Power BI Update 768x460.png

Check it Out!

Click here to read more about the November 2021 Updates!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.