cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Michaela_Onu Frequent Visitor
Frequent Visitor

Slicer incorrectly chooses both filter fields

Hi all, 

I have a problem with my Hierarchy slicer. I have triple-checked the mapping and it's 100 % correct, all the other Hierarchy slicers work fine. This one, however, ticks both categories even though I tick only one. 

Imagine I have two options, A and B. Under A, there is A1 and A2, under B, there is B1 and B2. If I want to tick A, both A and B get selected automatically. If I tick B, only B gets selected. I have disabled single selection and if I unselect B, only A is showing as desired. But when the filter is empty and I want to click A, B gets selected as well. I tried ticking the subcategories and they work fine - if I start by ticking A1 and A2, I only get A selected, same goes for B subcategories. 

Does anyone have any idea as to what is causing this issue? 

Thank you. 

TL;DR: If I tick A, both categories get selected (as illustrated in the picture), mapping is correct. 
Hierarchy slicer.png

1 ACCEPTED SOLUTION

Accepted Solutions
Michaela_Onu Frequent Visitor
Frequent Visitor

Re: Slicer incorrectly chooses both filter fields

Just to close the issue, I ended up deleting the connecting table, re-uploaded it and re-established the connections. Guess I just got some kind of a bug that was fixed by re-doing everything. This btw happened after I changed the filter from single selection to multiple selection, it worked fine before. None of the other filters were affected. 

3 REPLIES 3
rajulshah Member
Member

Re: Slicer incorrectly chooses both filter fields

Hello @Michaela_Onu,

 

Can you please share the pbix file so that I can validate what is going on?

Michaela_Onu Frequent Visitor
Frequent Visitor

Re: Slicer incorrectly chooses both filter fields

Hi @rajulshah, thanks a lot for reaching out to me. However, the file contains sensitive company data so unfortunately I cannot share it. 

Michaela_Onu Frequent Visitor
Frequent Visitor

Re: Slicer incorrectly chooses both filter fields

Just to close the issue, I ended up deleting the connecting table, re-uploaded it and re-established the connections. Guess I just got some kind of a bug that was fixed by re-doing everything. This btw happened after I changed the filter from single selection to multiple selection, it worked fine before. None of the other filters were affected. 

Helpful resources

Announcements
Virtual Launch Event

Microsoft Business Applications October Virtual Launch Event

Join us for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

Power BI Helps Homeless and Trouble Youth

Power BI Helps Homeless and Trouble Youth

We spoke with Power BI Super User, Greg Deckler, about his charity work

MBAS Gallery

Watch Sessions On Demand!

Continue your learning in our online communities.

Users Online
Currently online: 332 members 4,230 guests
Please welcome our newest community members: