cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Helper II
Helper II

Sigma symbol is missing, I can't summarize

Hello.

 

I don't know what is happening. I can't summarize any column, sigma symbol is missing and I have summarize option selected. Does anyone have an idea how I can make the symbol appear so I can summarize?

 

These columns are number types and still sigma symbol is missing.

 

Superior.png

Lateral.png

 

1 ACCEPTED SOLUTION

Look what I found :

 

https://github.com/otykier/TabularEditor/issues/544

 

It seems to be "by design" 

View solution in original post

24 REPLIES 24
Community Support
Community Support

Hi @inm ,

 

Are you using the latest version of Power BI Desktop? Does this situation exists only in current .Pbix file or any .Pbix file?

 

Best Regards,

Jay

Community Support Team _ Jay
If this post helps, then please consider Accept it as the solution to help the other members find it.

@negi007 I can't. But thank you.

 

@v-jayw-msft Only in the current .pbix file. But I tried to do it in another file, at first the sigma symbol appeared and in some time it stopped appearing. Yes, I'm using the lastest version.

 

I need to know what I'm doing wrong, because I start to create measures and I get distracted, when I see again all the sigmas  symbols disappear and I cannot summarize.

I have the same problem. Field is set to summarize and is a decimal number, but the sigma won't appear and when I drag it to make a visual it creates a table and shows distinct values of the data.

 

By any chance, are you using Calculation Groups through Tabular Editor ?

 

@bergerlu Yes, I'm using calculation gruoups through tabular editor. I was wondering if it could be related to that.

I have reproduced the issue, I can confirm that it is caused by the Calculation Group from Tabular Editor

Look what I found :

 

https://github.com/otykier/TabularEditor/issues/544

 

It seems to be "by design" 

View solution in original post

I encountered the same issue. So I can no longer drag a (previous) sigma symbol data value into the value field of a matrix or a watefall after I experimented with Calculation Group. 

 

Is there a way to undo this? I get that this is due to the DiscourageImplicitMeasures being set to false. Is there an option to revert back? 

@dharsanj you have to remove every calculation group created before and then change property Discourage Implicit Measures.

 

discourage.png

Thanks. That worked. 

sh*t, ok finally an explanation, THANKS for the insight:  if you use calculation groups no more implicit measures (sigma symbol)

@bergerlu Thank you very much for teaching me that, I was disturbed not knowing why sigma symbol disappeared.

 

@PaulDBrown I thought that somehow the fact that it was in measure increased the loading time a bit and I wanted to decrease it.

Super User IV
Super User IV

@inm , Even without that symbol you can do that. Just click on the column and in the column tools give default summarization. On the right of the box in screenshot

Data Format New Rib.png



Did I answer your question? Mark my post as a solution! Appreciate your Kudos!!
Dashboard of My Blogs !! YouTube Channel !! Connect on Linkedin

Proud to be a Super User!

@amitchandak @Greg_Deckler Thanks for answering. I have Whole number format selected, I'm trying to count number of cases some person has. I don't have the option Default summarization.

 

Recount.png

 

I don't want to have every number associated with a person, but the number of numbers.

 

I know that I can use measures, the problem is that I have many and it takes a while to take, even in a table it runs out of available resources.

@inm - Maybe try distinct count? I'm not sure what I am looking at. Are you summarizing name?


---------------------------------------

@ me in replies or I'll lose your thread!!!

I have a NEW book! 
DAX Cookbook from Packt
Over 120 DAX Recipes!




Did I answer your question? Mark my post as a solution!

Proud to be a Super User!




@Greg_Deckler I'm summarization numbers (like distinct count(APP_NUMBER) group by name), I have already tried distinct count. 

By default it is selected in column tools to do a distinct count, but it does not. I am trying to use the number of different times per day on area chart, but it won't let move APP_NUMBER to values, it stays in legend. APP_NUMBER is a whole number.

 

foto.png

Any choice it's working for me.

otra.png

 

@inm Have your tried creating a calculated measure like Count_App = DISTINCTCOUNT(appnumber). Once you create this measure, you can put in the value field. Measure will have calculator icon aginast it.




Did I answer your question? Mark my post as a solution!
Appreciate your Kudos


Proud to be a Super User!

Follow me here


@negi007  Yes, I already have the measure, the thing is that I want to do it the other way because I have many measures and I think that that way it takes longer while it is calculated. I want to decrease the waiting time.

@inm 

I have never, ever, used the default "summarize" value for a column. In fact, I make a point of turning them all off. It is actually considered a "best practice" I believe. 
Use measures instead.





Did I answer your question? Mark my post as a solution!
In doing so, you are also helping me. Thank you!

Proud to be a Super User!
Paul on Linkedin.






@inm Then can you try to change the data type in the power query window like below. This way your data will flow in number format in powerbi desktop

 

negi007_0-1599288173910.png

 




Did I answer your question? Mark my post as a solution!
Appreciate your Kudos


Proud to be a Super User!

Follow me here


@negi007 thank you for your answer. My data type is Whole Number in power query too. I don't understand why it's not working.

Helpful resources

Announcements
secondImage

Congratulations!

We are excited to announce the Power BI Super Users!

Microsoft Ignite

Microsoft Ignite with Arun Ulag

Featured Session: Drive Data Culture with Power BI- Vision, Strategy & Roadmap. Register here https://myignite.microsoft.com #MSIgnite #PowerPlatform #Power BI ​

Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

secondImage

The largest Power BI virtual conference

100+ sessions, 100+ speakers, Product managers, MVPs, and experts. All about Power BI. Attend online or watch the recordings.

Top Solution Authors
Top Kudoed Authors
Users online (1,304)