cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Donna
Frequent Visitor

Show items with no data not working

Hi everyone,

I'm a brand new user of Power BI (desktop) and am muddling through my first financial report with a lot of help from this forum but this issue has me stumped.

I have 2 matrix tables. They are fine until I change the Reporting Line on the slicer. When I do that the Strategic Initiatives column in the top table disappears (Not all Reporting Lines have data in this category but I still want the column to be there). I have checked "Show items with no data" for columns and rows but it still disappears.  

 

The bottom table keeps all 5 columns.  I need the two tables to stay in alignment with each other. 

Has anyone got any ideas?

I've attached a photo (confidential data covered up with white squares)

Capture.JPG

 

 

1 ACCEPTED SOLUTION
Donna
Frequent Visitor

I think I've fixed it. 

I made a new measure which said that if the values were blank then change to 0. The columns are now staying put even when the Reporting Line is changed. 

View solution in original post

3 REPLIES 3
v-piga-msft
Resident Rockstar
Resident Rockstar

Hi @Donna,

 

It seems that you have solved your problem in another way.

 

Please always accept the replies making sense as solution to your question so that people who may have the same question can get the solution directly.

 

In addition, for your scenario, I think that the blank value may be filtered by the slicer.

 

If you still need help, please share a dummy pbix file which can reproduce the scenario, so that we can help further investigate on it? You can upload it to OneDrive or Dropbox and post the link here. Do mask sensitive data before uploading.)

 

Best  Regards,

Cherry

Community Support Team _ Cherry Gao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi @v-piga-msft,

Not sure if this is a bug but I have exactly the same problem using dates that have been converted to text. When trying to use a column chart, I still get dates with no data missing. 

Is there an alternative solution to this issue? 

Many thanks,
K

Donna
Frequent Visitor

I think I've fixed it. 

I made a new measure which said that if the values were blank then change to 0. The columns are now staying put even when the Reporting Line is changed. 

View solution in original post

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are You Ready?

Test your skills now with the Cloud Skills Challenge.

Top Solution Authors