Showing results for 
Search instead for 
Did you mean: 

Share your thoughts on DirectQuery for Power BI datasets and Azure Analysis Services (preview)

Hit Reply and let us know what you think of the DirectQuery for Power BI datasets and Azure Analysis Services.  To learn more about this feature, please visit this blog post or our documentation.


Here are some areas that we'd like to hear about in particular:

  • Performance
  • Query editor experience--the remote model query doesn't show up in the query editor and only in the data source settings dialog. What are your thoughts?
  • Navigator experience
  • Thoughts around governance and permissions for models that leverage this feature
  • Nesting models, i.e. building a composite model on top of a composite model
  • Automatic page refresh for live connect in composite models

Thanks and we look forward to hearing your feedback!


- The Power BI Modeling Team

438 REPLIES 438
Helper I
Helper I

So, this one is an oddball one.


When I query a particular DQ dataset form Excel I get the error "Data seen at different points in time during execution of this query are inconsistent with each other. This could be due to external transactions updating same data while this query was running. Please rerun this query." However, the exact same setup querying the underlying dataset (the source for the DQ dataset, which is a typical import model) doesn't produce this error. 🤔


Tracing using Dax Studio, I find the underlying MDX query (which works when directly queried against the source dataset) is:


MDX Query:

                {DrillDownLevel({[Value Selector].[Value Selector].[All]})}
FROM [Model]
    [Measures].[Total Actuals NZD]


Resultant DAX generated to the source dataset is (and when run in DAX Studio is working):


DAX Query 1:

    "__Agg0", [Total Actuals NZD]


DAX Query 2:

VAR _Var0 = VALUES('Value Selector'[Value Selector])
    'Value Selector'[Value Selector],
    "__Agg0", [Total Actuals NZD]


DAX Query 3:

    VALUES('Value Selector'),
    'Value Selector'[Value Selector],
    'Value Selector'[Order]


The model structure is simple enough - although not the best modelling setup. The measure used is a simple column sum...




Not sure where to go from here? 🤷‍

hmm, can you please open an issue on or open a support ticket?

In case you want to track your end: Support request ID 2205310030002149

New Member

When you link with second dataset, the RLS would disappear. It would have data loss risk. Would there be any plan to fix that?

I am not sure I follow this - can you please provide more details?

I am referring to the fact that currently with PRO licensing it is necessary to release construction access to the sets that I use in my panels that use the resource
Helper III
Helper III


I have an error in all the reports with this functionality. All the visuals of the reports are broken:


The error is:


I have admin permissions to all datasets. The reports are connected to two datasets one in the same workspace of the report and another to other workspace. In both workspaces I am admin.


Do you now what is happening? Should I contact the support?

We have the same issue in our tenant. In PBI Desktop all works fine but in the Service there is the same issue. I'm the admin in both workspaces as well. So far haven't found any solution. 

In my case in power PI desktop doesn't works too.

please open a support ticket so we can dive into this.

Frequent Visitor

I have had a rather critical OLE DB or ODBC error, which i have not been able to solve. When ever i try to open a KPI report i created i get the following error. 



This applies to all former version and backups and prevents me from opening any file and changing  the connection. It have tried to deleting the tables in datasets used, changing them to blanks, etc. but i all these cases i just receive the error below or the one above. 


Thus i have been unable to acces the reports and change the connection since the direct query loads before the reports is opened. Meaning all the work building the report has been lost. Would it be possible to open the reports in some kind of safe mode or prevent PBI from loading the dataset before opening the report, such that i could remove the faulty connection.

Did you turn off the auto date/time feature in options and settings?  In the source dataset?  That localDateTable is from the auto date/time feature in options.

Did you try bringing it in again as a new source to see if it works?

Yes - tried to disable it both globally and in the source dataset. Unfortunately that did not work either. 


Also tried to delete thet relevant table in the source database and create a simple one only with a blank column or a column with dates. 


Ufortunately the error occurs when i try to open the file in the desktop. and prevents it from opening. So i cannot change the source inside the report. 

Helper I
Helper I

The end users that dont have Pro license cannot view the dashboards that uses this feature, right?

I assume with "don't have Pro license" you mean Free users - they will be able to see the reports created using this feature if: a) they have at minimum Read permission on all datasets involved and b) the datasets involved are published on a Premium capacity.

Helper I
Helper I

Looks like DQ is importing calculated tables (not normal tables) flagged as private. This is irrespective of the "Include tables added later" checkbox. I noticed this after adding some clustering via the standard Scatter Chart visual to one of the datasets.


I imagine this would be an issue for those who use private tables to track things - like the dataset template version that I've just started tracking using a private table 😞


The below images show the tables selected for import (not the private tables are not listed), and the ClusterMappingTable tables that ended up in the model.






thanks for reporting this - I will look into this!

Frequent Visitor


Since the latest PowerBi Desktop update (April 2022), I'm unable to connect to more than one live dataset.

I'm getting this error after selecting the database/tables (for the second dataset connection) :


It's obviously not a timeout issue since I'm able to connect to the dataset if it's the first one that I'm connecting to.

Note that I can still open and refresh existing datasets containing multiple live dataset connections. Those were created in a previous version of Power BI Desktop.


Am I the only one getting this error?


@philqc77 when you say "live connection" do you mean, an actual LIVE connection or a DQ connection? Because an actual LIVE connection is always just to one source. If you're talking about DQ connections, please give some more details on what source you're using.

Sorry, maybe I'm not using the right terminology. Here's what I did:


1. I created a live connection to a Power BI Dataset (let's call it ds1). No problem there.philqc77_7-1650546698114.png
2. Then I wanted to add another connection to another Power BI Dataset (ds2). I got this prompt which I was expecting and I clicked on "Add a local model".philqc77_0-1650545825057.png
3. Clicked "Submit" on the following. This is related to ds1.philqc77_2-1650546119514.png
4. Selected ds2 and clicked on "Create"philqc77_3-1650546265341.png
5. Clicked on "Submit". This is for ds2philqc77_4-1650546322846.png
6. Then I got the login prompt which is unusual at this point.  philqc77_5-1650546463990.png
7. Then I got the error.philqc77_6-1650546524352.png


I did the exact same steps (using the same connection) on Power BI Desktop updated to dec 2021 and it worked flawlessly.

Helpful resources

June 2022 update 768X460.jpg

Check it out!

Click here to read more about the June 2022 updates!

Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Power BI Dev Camp Session 23 768x460.jpg

Check it Out!

Mark your calendars and join us on Thursday, June 30 at 11a PDT for a great session with Ted Pattison!

June 20 episode 7 with aka link 768x460.jpg

The Power BI Community Show

Join us on June 20 at 11 am PDT when Kim Manis shares the latest on Azure Synapse analytics, the Microsoft Intelligent Data Platform, and notable Power BI Updates from Microsoft Build 2022.

Top Solution Authors
Top Kudoed Authors