cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
tessahurr
Microsoft
Microsoft

Share your thoughts on DirectQuery for Power BI datasets and Azure Analysis Services (preview)

Hit Reply and let us know what you think of the DirectQuery for Power BI datasets and Azure Analysis Services.  To learn more about this feature, please visit this blog post or our documentation.

 

Here are some areas that we'd like to hear about in particular:

  • Performance
  • Query editor experience--the remote model query doesn't show up in the query editor and only in the data source settings dialog. What are your thoughts?
  • Navigator experience
  • Thoughts around governance and permissions for models that leverage this feature
  • Nesting models, i.e. building a composite model on top of a composite model
  • Automatic page refresh for live connect in composite models

Thanks and we look forward to hearing your feedback!

 

- The Power BI Modeling Team

476 REPLIES 476

Ok great! Thank you for the quick response. 

Thanks for looking into the issue. Even I am having the same issue. Trying to connect 2 PBI datasets.

In the old reports which had combined PBI datasets, I am unable to establish relationship betweeen tables from different data sets. Seems this issue will get fixed alongwith the earlier reported issue.

mtmorrissey
Frequent Visitor

I have an OData datsource (InTune Data Warehouse (IDW) ) that I have published to the Power BI Service.

I built a composite PBI Report in PBI Desktop from the above PBI Dataset in the PBI Service that augments the model by joining upns on the IDW model with an organisational data set also joined by upn.

When the new model is published it goes bad. There is a message about the OData source being removed and the dataset cannot be mapped to any datasource.

hmm, interesting. can you please open an issue on issues.powerbi.com or reach out to our support channels so we can collect detailed info from you?

thanks for opening the issue, let's continue the conversation there.

gerardcanals
Helper III
Helper III

Hey maybe this is a bug!

 

Hey! Maybe this is a bug!

 

I give access to one user to a report with a dataset connected to two different datasets:

 

  • One located in the same workspace.
  • One located in another workspace.

 

When I access into the report with this user:

 

gerardcanals_0-1648194417414.png

 

 

The report is broken. The details says:

 

gerardcanals_1-1648194417410.png

 

 

I checked if the user has permission to atleast watch the other datasets, but no! Although I give permission to read the dataset of the report (the one connected to two different datasets) the permissions don’t go automatically to the other datasets and I have to do it manually.

That's normal even for a live connected report. Access doesn't get set across workspaces.

Yes it's true, but now it doesn't work even with datasets that are in the same workspace.

@samaguire is right, you need to give proper (=build for now) permissions to all datasets in the chain.

@jeroenterheerdt  Is it still necessary to give access to the compilation of reports with more than one set of PRO licenses?

sorry, I don't understand the question. Can you please elaborate?

samaguire
Helper II
Helper II

Maybe this is a known bug? Refreshing two datasets where both datasets have a relationship between tables of the same name in both datasets causes a "Sequence contains more than one matching element" error.

I tried to workaround this (without renaming one of the tables) by setting the data load settings to not load in parallel, but no luck. (Given you can add the datasets individually without issue.)

 

BTW. discovered this when trying to pull together a report based on the two datasets, no fancy interlinking being done either.

 

NB: below pic has different table names showing, but underlying dataset has identical naming.

 

samaguire_0-1648186260504.png

 

I did find it interesting that this is an issue given the table exclusion rules are being set by lineage tag.

samaguire_1-1648186510243.png

 

interesting, thanks for reporting.

Thanks for this, I've just started getting the same bug and couldn't work out what it meant - for me it happened when I tried to build a new report on top of the working model, any refresh of the new one hit this error message, while the old one carried on working.  

No problem. That's why I shared. 👍

Leodie3
New Member

While we understand that a developer would require build access to all datasets in the chain, it is unclear to us why a reader would also require build access to all datasets in the chain (why not just read access). To us this is the main reason why we cannot use this -otherwise great- feature at this point as this way we would not be GDPR compliant. Will this change? Or is there perhaps a workaround?

thanks for the feedback - yes, this will change. Readers will just need view permission.

Can you share where this is on the roadmap? Thanks

sure - this is the major blocker for us to declare this feature general available. More news to follow soon on the blog.

Helpful resources

Announcements
September Update

Check it Out!

Click here to learn more about the September 2022 updates!

Power BI Show episode 9

The Power BI Community Show

Watch the playback when Priya Sathy and Charles Webb discuss Datamarts! Kelly also shares Power BI Community updates.

Power BI Dev Camp Session 26

New Date - Check it Out!

Mark your calendars and join us on Thursday, October 6 at 11a PDT for a great session with Ted Pattison!

Top Solution Authors