Showing results for 
Search instead for 
Did you mean: 

Share your thoughts on DirectQuery for Power BI datasets and Azure Analysis Services (preview)

Hit Reply and let us know what you think of the DirectQuery for Power BI datasets and Azure Analysis Services.  To learn more about this feature, please visit this blog post or our documentation.


Here are some areas that we'd like to hear about in particular:

  • Performance
  • Query editor experience--the remote model query doesn't show up in the query editor and only in the data source settings dialog. What are your thoughts?
  • Navigator experience
  • Thoughts around governance and permissions for models that leverage this feature
  • Nesting models, i.e. building a composite model on top of a composite model
  • Automatic page refresh for live connect in composite models

Thanks and we look forward to hearing your feedback!


- The Power BI Modeling Team

520 REPLIES 520

Thanks, this is expected behavior for now. We are still working on the lineage integration.


I was able to use this functionality earlier this week.  However today I am not getting the option to update from a live connection to a Direct Query.  I uninstalled the desktop and reinstalled.  Still no luck 😞


I then tried to start with an excel source query and add analysis services also with no luck.  And yes, I have confirmed the Direct Query option is selected.


I should mention also that I am on version 2.91.884.0 64-bit (March 2021)

Hi, I have the same issue, although I have the newest version 2.91.884.0 64-bit (March 2021), I still can't combine two sources: excel imported data and Analysis Services through the Direct Query.


did you enable the preview feature? Also, please note that SQL Server Analysis Services is not supported, just Azure Analysis Services.

Hi 🙂 I enabled the preview feature, but I'm working on SQL Server which is why this feature is not working. Thank you so much for the help!

Super User
Super User

Ive been testing the updates for Direct Query for Power BI datasets and Analysis Services in Preview at the moment


Previously there were three issues


Connect to Dataset 1 and data set 2.

the folders created within data set 1 and 2 are not in the reporting pbix file (This is now resolved)

The Sort by on fields have been lost in the reporting pbix file (This has now been resolved)

The formatting is lost on data sets.

This unfortunately still seems to be a problem and we absolutely dont want to lose the formatting work set within the data sets




In the dataset this is Percentage 2 for one of my measures, however in the reporting pbix file the formatting hasnt come through


So unfortuantely for us this still isnt fit for purpose. Has anyone else noticed this?

as noted in the blog formatting is not yet persisted. It will be though.

Was this addressed in the June update?  Based on the blog I thought it was, but I am still not seeing formatting on my measures flow from the original model to the one with the DirectQuery. 

it should have. If it's not, please open an issue.

Advocate I
Advocate I


We realized that the activation of this preview feature "DirectQuery for Power BI datasets and Azure Analysis Services" is causing problems in the "Sort by column".

Currently, when we update a report on PWBI Desktop, the columns that are ordered by others, lose this configuration.
We do not make any changes to the structure, just refresh the report.

When disabling the option "DirectQuery for Power BI datasets and Azure Analysis Services", the report updated correctly with the "Sort by column" provided.

This happens with the February and March versions of PWBI Desktop.

It is a correction that you should implement.


Not applicable

Date format strings are getting changed to default format while converting from live connection to Direct query this is not expected behaviour.

Regular Visitor



will RELATED an LOOKUPVALUE be supported in a future release? 

I hate to say no, but since this is a DirectQuery connection, I would have to say 'not likely', as those functions are not supported on DirectQuery sources in general.

Regular Visitor

Hi Team,


Scenario : I am trying to connect (live/import) to a Azure Analysis Service dataset on (Tenant A) from Power Bi desktop (on Tenant B).

I am to 

* successfully connected (live/import) to the AAS dataset (on Tenant A) using PBI desktop (Tenant B).

* Successfully published the PBIX file with the AAS dataset (Tenant A) to PBI service (on Tenant B)


But not able to run the report or load the file on the PBI service (Tenant B)


For a Live connection to AAS dataset 

* It throws the error "Cannot load model

Couldn't load the model schema associated with this report. Make sure you have a connection to the server, and try again."


Eventhough the connection to the AAS dataset (on Tenant A) runs file without error. I am able to refresh the dataset but this doesn't get loaded to the report


For an import mode : 

I get the attached gateway error. I have installed the personal gateway and  Changed the account running the Gateway from the default service account to a domain user. Seems like the gateway service account (Tenant B) is not able to impersonate the Tentant A login credentials.


Is there a limitaion in using DirectQuery to AAS dataset between two different tenants ?

Any help is highly appreciated

live connection error.pngimport connection error.png




Not applicable

I have exactly the same issue as you.

Helper II
Helper II

I can't seem to share the reports generated from the model without making them at least a contributor in the workspace (Which I can't do for several reasons).

this is expected - people need at least "build" permissions to view reports built using this feature. We are looking at changing this.

Hi there,

We also experienced this last week. 

Another team could not share a report built on a Direct Query Composite model with their workspace App viewers uness the following were satisifed:
a) Those viewers are "allowed live connections"  (Tenant Setting).
b) They have build permissions on the original dataset. Interestingly enough, the app viewers did not need build permissions on the subsiquent dataset, (the one that's been changed). 

This is not true at the moment actually. The "build" permission does not work. You need to be member of the workspace, the source dataset is located in. I have a bug ticket open on this one and the fix is due at the end of April

We found only build permissions were necessary on the source dataset. I.e. in order to view reports from the subsiquent dataset, a user requires build permissions on the original dataset

You are correct. The build permission of the source dataset (And not the dataset actually being referenced) does solve the problem! Still not ideal, but its better than nothing.

Helpful resources

Vote for T-Shirt Design

Power BI T-Shirt Design Challenge 2023

Vote for your favorite t-shirt design now through March 28.

March 2023 Update3

Power BI March 2023 Update

Find out more about the March 2023 update.

March Events 2023A

March 2023 Events

Find out more about the online and in person events happening in March!

Top Solution Authors