Showing results for 
Search instead for 
Did you mean: 
Advocate I
Advocate I

Selection Controls Not Available for Slicer Format in Power BI Desktop



Something odd is happening. I am able to see the "Selection Controls" under Format for the previously created slicers. But, when I create a new one, the selection controls option is not available, nor is the option to select drop down versus list under more options on the visual.


Is this a bug? I would appreciate a solution!




This issue is solved now.

View solution in original post

Community Support
Community Support

Hi @sraissi ,


I can't reproduce this issue on my side. Can you please provide more detailed information about your scenario?

Test version: 2.66.5376.2161 64-bit (February 2019)



Xiaoxin Sheng

Community Support Team _ Xiaoxin
If this post helps, please consider accept as solution to help other members find it more quickly.

This issue is solved now.

View solution in original post

What is the solution?  I don't see the selection control on Power Bi server either. 

Hi Khoerner,


I ended up recreating the slicer and the isue was solved, it seems like a bug as no one else could reproduce the issue.


I hope it helps.



I ran into the same problem and even when I recreated the slicer it didn't seem to solve the problem.  I thought I would share what I did in case someone else has a similar problem.


First, slicer header needs to be turned on:


Annotation 2020-03-30 153402.pngThen click on the arrow at the top of the slider:

Annotation 2020-03-30 153402(2).pngFrom the drop down list select Dropdown.  Then the selection control section will be visible in the formatting pane and you can click on the Single select option.


Annotation 2020-03-30 153402(3).png


Hopefully this helps.


Thanks, It works now

Hi Xiaoxin,


I am working in a Power BI file with a page that was set up before. Now, there is a slicer on this page reflecting the week in year number. When I go under format for this previosuly created visual, I can see the "Selection Controls" option. However, when trying to reproduce the slicer, with the exact same field and filters, I do not get the "Selection Controls" option. This is only happening in the Power BI desktop and not in the edit mode on the Power BI service. That is what made me think this might be a bug as I found a post from 2017 with a similar issue, but I wasn't sure or couldn't find a solution. 




Helpful resources



We are excited to announce the Power BI Super Users!

Wave Release 2

Check out the updates in Power BI.

Overview of Power BI 2020 release wave 2!

Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!


The largest Power BI virtual conference

100+ sessions, 100+ speakers, Product managers, MVPs, and experts. All about Power BI. Attend online or watch the recordings.

Top Solution Authors
Top Kudoed Authors