cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
modi123p
Frequent Visitor

SVG file not rendering on Synaptic Panel

Hi,

I m running into a weird issue. I tried using synoptic panel with same data and same svg on two different domains.

PBI Desktop version is the same.

  • The custom visual renders the svg fine on one domain  (and system) while fails on the other!!!
  • Custom visual and SVG fail on PBI service too
  • SVG is very small (1 KB)  and should not be a problem. 
  • Is it possible to disable block certain custom visuals by the administrator?
  • When I opened PBIX file created on another domain [and System], the visual renders fine. Copy and Paste this visual and the new visual renders fine. However, if I try to use  a fresh instance of Custom Visual and upload the local copy of the SVG file used (with same data columns), the visual fails to render. 

Tried including SVG. However, it is not supported here. Hence providing PNG. As you can see.. a simple image that was converted to SVG using Synoptic designer.

 

Visual renders fine in a different domain_same pbix.PNGVisual renders fine in a different domain_same pbix and png

 

Error that shows up if I try to configure another instanc eof the same visual (even if it is referring same fields and SVG and in the same PBIX)

error in fresh instance.PNGError in fresh instance

 

Please suggest if you have run into similar problems with Synoptic Panel.

 

Thanks,

Mannu

2 REPLIES 2
Community Support
Community Support

Re: SVG file not rendering on Synaptic Panel

Hi @modi123p 

If you select "local maps", this means you upload a file from local server.

Since you use another domain, the server changes, right?

You could refer to this teaching vedio:

https://www.youtube.com/watch?v=DKTPvhzS3lU

 

Best Regards
Maggie
Community Support Team _ Maggie Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

modi123p
Frequent Visitor

Re: SVG file not rendering on Synaptic Panel

@v-juanli-msft 

 

Sorry for the confusion.

 

Use Synoptic Panel on System1 using   accountXYZ@domainXYZ.com --> Works fine.

Use Synoptic Panel on System2 using   accountABC@domainABC.com --> Fails

 

Same SVG and PBIX file is used.

Both SVG and PBIX are downloaded  and hence are local to the system.

Desktops version are same. No changes are made to PBIX file !!!!

Try uploading same SVG file and it works (on the other system)!!!

 

Today I tried on another system in the same domain  accountAAA@domainABC.com.

Even here it succeeds. Wonder why. there is no problem with any other custom visuals.

 

Tried publishing report to PBI Service, importing custom visual on the service and then uploading the same svg file.

It still fails for my account.

 

If I copy the visual from the PBIX file (where it works fine), it renders. But I m unable to change the SVG again!!!!

Its as if the file is not getting uploaded !!!!

 

Thanks,

Mannu

Helpful resources

Announcements
New Ranks Launched March 24th!

New Ranks Launched March 24th!

The time has come: We are finally able to share more details on the brand-new ranks coming to the Power BI Community!

‘Better Together’ Contest Finalists Announced!

‘Better Together’ Contest Finalists Announced!

Congrats to the finalists of our ‘Better Together’-themed T-shirt design contest! Click for the top entries.

Arun 'Triple A' Event Video, Q&A, and Slides

Arun 'Triple A' Event Video, Q&A, and Slides

Missed the Arun 'Triple A' event or want to revisit it? We've got you covered! Check out the video, Q&A, and slides now.

Top Solution Authors
Top Kudoed Authors