cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

SUMMARIZE Function

Halo People

 

So the summarize function dont seem to work as expected, see below. The error does not make sense, since the expression is merely a sum(table[tonnes column) and I just saw someone in a youtube video using it the exact same way?

image.png

1 ACCEPTED SOLUTION
rajendran
Community Champion
Community Champion

I think you are trying to create this as Measure, Navigate to Modelling -> New Table, ad use the formula there.

 

Thanks

Raj

View solution in original post

4 REPLIES 4
MarcoRotta
Resolver I
Resolver I

The SUMMARIZE command will create a new table. It really seems you're trying to use it in a measure, which will not work. So, first make sure you are at the "Data view" when you use it (not on the report view). I'd also make sure that your columns/fields, such as "Tonnes & Carats" are properly reference, usually in the "Table[Field]" format. 

 

 

Regards. 

Anonymous
Not applicable

Aha, I feel silly thank you very much. This makes a lot of sense

rajendran
Community Champion
Community Champion

I think you are trying to create this as Measure, Navigate to Modelling -> New Table, ad use the formula there.

 

Thanks

Raj

View solution in original post

Hello,

 

I have two tables like TBL and CUST. I have created the CUST table using the DAX.

CUST=
ADDCOLUMNS(
SUMMARIZE(FILTER(TBL,NOT(TBL[Account])=BLANK()),TBL[Account ],
"Sale",CALCULATE(SUM(TBL[Sale Amount]),FILTER(TBL,TBL[Ind]="Yes"),FILTER(TBL,TBL[Ind2]="Yes" && NOT(TBL[Code]) IN {"4"} ))
),
"Grp",
IF ( [Premium] >=0 && [Premium]<100, "0-100",IF ( [Premium] >=100&& [Premium]<500, "100-500",IF ( [Premium] >=500 && [Premium]<1000, "500-1000M",IF ( [Premium] >=1000, "1000+" )))))
Now, I have created a relationship between those two tables using "Account" column and created a Cust Grp column in TBL using Related(CUST[Grp]). I want build a customer count based on grouping. 
Problem:
Counts were fine when there were no filters applied but when I apply a filter on TBL tables Sale amount in CUST table is not filtering(I selected filtering as Both direction). As a result, counts in the group are not being calculated properly. 
For example, if I filter country in TBL to the "USA" the premium in the CUST table is not changing.
 
Please help me out!!!!
Thanks in advance!!!!!

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Power BI October Update 2021.jpg

Power BI Release

Click here to read more about the October 2021 Release!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Teds Dev Camp Oct. 2021 768x460.jpg

Power BI Dev Camp - October 28th, 2021

Mark your calendars and join us for our next Power BI Dev Camp!