cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
floressdiego
Frequent Visitor

SQL Server - we couldn't authenticate with the credentials provided

Hello, 

I have been trying to connect to SQL Server all day today. The error that shows is the following:

floressdiego_0-1613586785951.png

If I press "OK" I cannot access the Data, the database comes empty. If I press cancel, sometimes it appears "we couldn't authenticate with the credentials provided". It is my first time trying to connect to SQL Server, but I did some research on this before posting. 
I changed the "Named Pipes" and "Shared Memory" to Enabled, 

floressdiego_2-1613587111013.png

Changed Server Authentication mode to "SQL Server and Windows Authentication mode",

floressdiego_4-1613587236512.png

Checked Maximum concurrent connections and remote connections

floressdiego_5-1613587318698.png

and connected to the server in SSMS with Server Authentication instead of Windows Authentication.

floressdiego_7-1613587509541.png

 

 

Still nothing changed. The connection I'm trying to make is local, it's not even remote. These are all changes that I made after looking for clues on why I can't connect. If someone could help me I would be really glad.

Even with Windows Authentication on Power BI I get the same error.

 

These are the screens of connection (just to be sure I am doing everything right)

floressdiego_8-1613587817362.png

 

...

floressdiego_9-1613587873648.png

 

Note: when I press "OK" on the error (image 1) I can see the databases in the server and the columns of each, but nothing appears in them.

floressdiego_10-1613587994879.png

 

 

 

Thank you,

Diego

 

 

8 REPLIES 8
manikumar34
Super User I
Super User I

@floressdiego , 

 

Clear permissions of the credentials given and try . 

Open new Power BI Window and follow the below steps

 

Files->Options and Settings->Data Source Settings->Clear Permissions (Clear for the required credentails given or clear all of them )

2021-02-18 (16)_LI.jpg

Regards, 

Manikumar





If this helps, Appreciate your KUDOS!
Did I answer your question? Mark my post as a solution!


Proud to be a Super User!




Sorry I forgot to mention. I tried that a lot of times, mostly after I tried something new, also cleared the cache a few times. All that did was asking for credentials once I clicked "OK" on the error at image 1.

Did you try deleting on a empty report and tried to loggin with credentials?

 

Once cleared it will ask to provide credentials again. 

Revently I had the same issue, I did the same thing and it worked for me. It happened multiple times this week, even today.

 

Regards, 

Manikumar

 

Regards, 

Manikumar





If this helps, Appreciate your KUDOS!
Did I answer your question? Mark my post as a solution!


Proud to be a Super User!




BlueTiger
Helper I
Helper I

In SSMS under MSSQLSERVER01 look under Security - Logins.

Right click on Diego and choose properties.

In the "User Mapping" page select the database Pedidos and check to make sure a suitable Database role membership is selected at the bottom. It sounds like you just have public selected, when in actual fact you would want db_datareader at minimum.

 

This is what I currently have

floressdiego_0-1613589918476.png

 

That looks fine, dbo_owner is good.

 

In SSMS what happens if you run the following query?

SELECT * FROM Pedidos

Can you see results? Do you get different results when logged into SSMS using Windows Authentication or SQL authentication?

 

With SQL Authentication:

floressdiego_0-1613643520874.png

 

 

With Windows Authentication:

floressdiego_1-1613643606409.png

 

 

It's the same thing for me.

Can you go ahead to the next step and load the data even though it is empty?

Then go to advanced editor and copy and paste the contents here?

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are You Ready?

Test your skills now with the Cloud Skills Challenge.

Top Solution Authors