cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Günter Frequent Visitor
Frequent Visitor

Re: SLICERS -> blank value

I also used this trick.

 

2017 08 25 - Page Level Filters.png

 

 

 

 

chethan Member
Member

Re: SLICERS -> blank value

To remove the Blank in slicer

 

create YearTable with Index > build relation YearTable to DateTable

 

Use the YearTable Year to your year Slicer

PwC_Marcel Frequent Visitor
Frequent Visitor

Re: SLICERS -> blank value

In my case the (Blank) on a slicer only appears if there is more than one relationship to the dimension table. So it seems like a bug since I do not have any blanks within my data.

PwC_Marcel Frequent Visitor
Frequent Visitor

Re: SLICERS -> blank value

In my case the (Blank) on a slicer only appears if there is more than one relationship to the dimension table. So it seems like a bug since I do not have any blanks within my data.

mattyt0406 Frequent Visitor
Frequent Visitor

Re: SLICERS -> blank value

I was able to address this by simply changing the way the table interact with each other.  In the relationships section in Desktop you need to select the relationship and the option on the bottomr right "Cross filter direction" needs to be set to "Both". 
One more bit of advice...if you want to use Row Level Security you cannot check the box "Apply security filter in both directions".  No matter the difference having the Both should address your issue though as long as you do it on the relationship to the table the filter belongs to.

Nishantjain Member
Member

Re: SLICERS -> blank value

I don’t think this is a bug. The reason you may think this is a bug is because the "Slicer" treats "Blanks" different to other visuals. Try the following to see if you have the same issue as I did and then how you can fix it

 

Issue:

Fact Table

 

[Column 1]      

a1

a2

a3

 

Data Table

[Column 1]      [Column 2]    [Column 3]

a1                     b1                   100

a2                     b2                   200

                         b3                   300

 

Relationship 

 

Fact Table [Column 1] >> Data Table[Column 1]

 

Bring [Column 1] from Fact Table into slicer

Bring [Column 1] from Fact Table into table

 

You will see [Blank] in the Slicer although you don't have any blank in this column in the fact table. But, when you bring the same field in the a table visual you don't see the blank. The table visual doesn't show the blank because a table visual (or any other visual) will remove the row if all the values in that row is blank. 

 

The reason for you see Blank in the slicer is because the Data Table has a "blank" value in [Column 1]. 

 

If you bring [Column 1] from the Data table in the "Table" visual, you will not see the blank. This is because the "table" will automatically remove the blanks. Bring in another [Column 2] from Data table in the "table" visual and you can now see the blank.

 

 

HOW TO FIX THIS

 

Create a table from the Data table, bring in the column causing you this issue and another column (both from the Data table) without summarizing any of the field (i..e don't add or count any of the field). You will see the row with the blank field. 

 

Thanks

Nishant

 

 

 

yhael1121 Frequent Visitor
Frequent Visitor

Re: SLICERS -> blank value

Hi Team,

 

im new to power BI so please bare with me. im working on a performance report for our company but when i created sumary table with Gauge Chart, it shows a blank in the slicer. i checked all my raw data but i cant see any blank in there. please see below for the samples.

 

 

 

image.pngactual table.image.pngsample table. just to see if i can see the employee with blank values.

lucky1012 Regular Visitor
Regular Visitor

Re: SLICERS -> blank value

hi,

 is it the same now or can i hide the empty checkbox from slicer without removing assosciated data?

pls help

ignas Member
Member

Re: SLICERS -> blank value

Hey guys Smiley Happy

 

I am not sure if anybody did not have the solution earlier but I did this:

  • Create 2 filters
  • First filter filters second filter, but nothing else in the page. Then I hide this filter somewhere in a corner with changing colors.
  • Then second filter does not have anymore options that are not selected by the first filter.

 

Regards,

 

Ignas

 

 

Highlighted
naocisneros Frequent Visitor
Frequent Visitor

Re: SLICERS -> blank value

Thank you very much, that was the solution for me.

Helpful resources

Announcements
Can You Solve These Challenge

Challenge: Can You Solve These?

Find out how to participate in the first Power BI 'Can You Solve These?' challenge.

Community News & Announcements

Community News & Announcements

Get your latest community news and announcements.

Virtual Launch Event

Microsoft Business Applications October Virtual Launch Event

Join us for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

Community Kudopalooza

Win Power BI Swag with Community Kudopalooza!

Each week, complete activities and be qualified in the drawing for cool Power BI Swag.

Users Online
Currently online: 375 members 3,859 guests
Please welcome our newest community members: