cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
PowerBItest007 Frequent Visitor
Frequent Visitor

SAP BW Connector Authorized Problem

please help me

 any one give a solution ......

 error.PNG

2 REPLIES 2
v-yulgu-msft Super Contributor
Super Contributor

Re: SAP BW Connector Authorized Problem

Hi @PowerBItest007,

 

Does this error occur when you select to preview any SAP table in Navigator pane ? Or does it only occur to some certain tables?

 

Please update your desktop to latest release for a test. Make sure you have installed the SAP RFC SDK in your local machine that is running Power BI Desktop. Please check whether you have meet the five prerequisites mentioned in this blog except for point 2.

 

From the error message, it looks like you have no access to detailed data. Please contact with your administrator to check whether your account have permission to extract these data.

 

Regards,
Yuliana Gu

Community Support Team _ Yuliana Gu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
corey_hallisey Frequent Visitor
Frequent Visitor

Re: SAP BW Connector Authorized Problem

We were running into this same error when trying to preview the data (or if we turned off the preview, when we tried to Load). We could connect and navigate InfoAreas without any problem, but we'd get the following error when trying to Preview data:

 

Error during extraction -> RfcInvoke failed(RFC_ABAP_RUNTIME_FAILURE): RFC_NO_AUTHORITY

 

At first, the error message sounded like we were missing some RFC-related SAP Authorization from our user's BW roles.  But that was a red herring.

 

What fixed it for us was the specific version combination of PowerBI and SAP's NW RFC SDK that we're using to connect to BW. We have run into these compatibility challenges multiple times since PowerBI introduced BW connectivity last year...it's a total PITA when the versions change, and things break.

 

We found that PowerBI v4.28 (July 2017 release) going against the SAP NW RFC SDK 7.2 patch 42 would trigger the error.

But when we upgraded to PowerBI 4.29 (August 2017 release), still using NW RFC SDK 7.2 patch 42the error vanished and we could fetch data successfully from our BW environment (we are on BW 7.4).

 

At our company, we are working to formalize a "compatible version freeze" for folks who are using PowerBI and the NW RFC SDK to fetch data from BW because of these ongoing compatibility issues.  SAP seems to update their SDK less frequently than Microsoft's monthly updates to PowerBI.

 

So, in a nutshell, trying upgrading to the latest version (4.29 - August 2017 release) of PowerBI.  It just came out last week.

 

Hope that helps!

Helpful resources

Announcements
GregDeckler

How to Get Your Question Answered Quickly

Power BI Super User, Greg Deckler, explains

Summit North America

Power Platform Summit North America

Register by September 5 to save $200

Back to School Contest

Back to School Contest

Engage and empower students with Power BI!

MBAS Gallery

Watch Sessions On Demand!

Continue your learning in our online communities.

Top Ideas
Users Online
Currently online: 51 members 985 guests
Please welcome our newest community members: