cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Post Prodigy
Post Prodigy

Row Level Security (RLS) not working

I have implmented row level security on my powerbi dashboard. It is working perfrectly fine when I use the view as feature to test if user is able to view the correct data. However, after i publish the dashboard to the workpace, it does not work function as expected. I am using data from excel file in my powerbi dashboard. Please advise do I need to implment the access management in my powerbi service. But I do not see the security option on my dataset in power bi services. Please advise.

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Post Prodigy
Post Prodigy

Re: Row Level Security (RLS) not working

@negi007 I have been able toresolve the issue. In our organization by default all datasets do not have RLS feature enabled. We have to ask for it to be enabled. Now, I have been able to get the security tab for my dataset and implement RLS. I did not know that this feturre can be controlled by the organization. Thanks everyone for their reponse.

View solution in original post

6 REPLIES 6
Highlighted
Solution Sage
Solution Sage

Re: Row Level Security (RLS) not working

Click 3 dots on Dataset and click "Security:"

RLS Secutiry.png

 

Under that security you will see the Roles that you have defined for your users . 

Add users in it. and make sure that users are "Member" not the admin of Workspace

 

RLS Secutiry-2.png

Did I answer your question? Mark my post as a solution! Appreciate your Kudos!!
Highlighted
Post Prodigy
Post Prodigy

Re: Row Level Security (RLS) not working

Thanks for your response. Please tell me do I need to do anything in power bi services if my RLS is dynamic. Curently, the workspace that I have do not have the security tab even though it is available when i publish the dashboard to my personal workspace.

Highlighted
Solution Sage
Solution Sage

Re: Row Level Security (RLS) not working

Workspace do not have Security Tab, when you click on your dataset then you will be able to view security tab 

 

Make sure that you are following steps correctly

 

https://docs.microsoft.com/en-us/power-bi/admin/service-admin-rls

Did I answer your question? Mark my post as a solution! Appreciate your Kudos!!
Highlighted
Community Support
Community Support

Re: Row Level Security (RLS) not working

hi @negi007 

If you have configured the workspace so that members have edit permissions, the RLS roles will not be applied to them. Users will be able to see all of the data.

https://docs.microsoft.com/en-us/power-bi/admin/service-admin-rls#using-rls-with-workspaces-in-power...

 

Make sure the users don't have the edit permissions in the workspace.

 

Regards,

Lin

Community Support Team _ Lin
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Post Prodigy
Post Prodigy

Re: Row Level Security (RLS) not working

@negi007 I have been able toresolve the issue. In our organization by default all datasets do not have RLS feature enabled. We have to ask for it to be enabled. Now, I have been able to get the security tab for my dataset and implement RLS. I did not know that this feturre can be controlled by the organization. Thanks everyone for their reponse.

View solution in original post

Helpful resources

Announcements

August Community Highlights

Check out a full recap of the month!

August 2020 CYST Challenge

Check out the winners of the recent 'Can You Solve These?' community challenge!

Experience what’s next for Power BI

Join us for an in-depth look at the new Power BI features and capabilities at the free Microsoft Business Applications Launch Event.

Top Solution Authors
Top Kudoed Authors