cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
dharland Regular Visitor
Regular Visitor

Ribbon in PBI Desktop stops working

As of the last release, the ribbon in PBI Desktop (e.g. "File", "View", "Home | Publish", etc.) becomes unresponsive. The behavior does not occur on a consistent basis and only appears to have started since the last release.

 

The only workaround is to close the file and open it again. Please advise.

8 REPLIES 8
v-xjiin-msft Super Contributor
Super Contributor

Re: Ribbon in PBI Desktop stops working

Hi @dharland,

 

I'm also using the latest release (Version: 2.56.5023.1021 64-bit (March 2018)). However I didn't encounter your issue.

 

So in your scenario, I would suggest you to try to reinstall the Power BI Desktop. If the issue persists, you can submit a support ticket.

 

6.PNG

 

https://powerbi.microsoft.com/en-us/support/

 

Thanks,
Xi Jin.

mhovmark Frequent Visitor
Frequent Visitor

Re: Ribbon in PBI Desktop stops working

Same issue here. 100 % freezes when I go to the table data view mode

justinh Frequent Visitor
Frequent Visitor

Re: Ribbon in PBI Desktop stops working

Same for me. Randomly the ribbon stops responding. 

Anonymous
Not applicable

Re: Ribbon in PBI Desktop stops working

@justinh Same, but minimizing and maximizing the window always fixes for me.

 

-Parker

justinh Frequent Visitor
Frequent Visitor

Re: Ribbon in PBI Desktop stops working

I tried that this last go around, and it did not work for me. Smiley Frustrated

Elkay
Advisor

Re: Ribbon in PBI Desktop stops working

I have found that if I change focus - click on anything else in my task bar - then back to PBI the ribbon will work again.  Has been happening to me since the June release.

justinh Frequent Visitor
Frequent Visitor

Re: Ribbon in PBI Desktop stops working

@Elkay Sure enough, that worked. Thank you. 

Highlighted
sbloye93 Frequent Visitor
Frequent Visitor

Re: Ribbon in PBI Desktop stops working

I had this issue for the first time today, I got around it by clicking the arrow in the top right of the GUI beneath the Close icon (^).

I clicked this twice, it hides the frozen ribbon then reopens it and upon reopening it was fully functional with all buttons displaying tooltip and the functionality returned.