cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
keontre Frequent Visitor
Frequent Visitor

Report is auto trimming text

Hi,

 

I am new to Power BI and have been trying to get a P&L statement report created.  The data I receive is already grouped in the accounts, I just need to display them in a meaningful way.  In order to distinguish between the header and detail lines in the P&L, I just added the following basic DAX:

 

PL DISPLAY = IF(PL_STRUCTURE[DISPLAY]="Detail", CONCATENATE(" ", PL_STRUCTURE[PL LINE DESC]), PL_STRUCTURE[PL LINE DESC])

The data then looks like the below in the preview window:

 

power_bi_preview.PNG 

 

When I add it to a table though, the leading white space disappears:

 

power_bi_report.PNG

 

I have spent a long time looking through settings in Power BI and forum posts, but couldn't find anything on Power BI auto trimming text in the reports.  During my research into creating P&L report structures I did find an example where they managed to do this (The BI Accountant).  I got a copy of their PBIX and added my data in the exact same way as before.

 

power_bi_report_working.PNG

 

So it can be done, and looking through document-level settings did not show any reason for why the behaviour was different between the 2 files.  The query part was simple - load from an Excel file and do nothing else to the query.

 

Any suggestions on stopping this apparent "auto-trimming" of text in reports?

1 ACCEPTED SOLUTION

Accepted Solutions
ElenaN Member
Member

Re: Report is auto trimming text

Hello,

If you look through comments on the BI accountant's post related to P&L there are other people who mention this issue and the solution provided was: 'Go to the table formatting, select Values, and turn off Word Wrap.'

Does this solve your issue?

Regards,
ElenaN

View solution in original post

2 REPLIES 2
ElenaN Member
Member

Re: Report is auto trimming text

Hello,

If you look through comments on the BI accountant's post related to P&L there are other people who mention this issue and the solution provided was: 'Go to the table formatting, select Values, and turn off Word Wrap.'

Does this solve your issue?

Regards,
ElenaN

View solution in original post

keontre Frequent Visitor
Frequent Visitor

Re: Report is auto trimming text

Thank you ElenaN, that resolved the issue.  So simple, yet just not that obvious!  Smiley Very Happy

Helpful resources

Announcements
Exclusive LIVE Community Event #3 – Ask Arun Anything

Exclusive LIVE Community Event #3 – Ask Arun Anything

Join us in the third Triple A event!

Meet the 2020 Season 1 Power BI Super Users!

Meet the 2020 Season 1 Power BI Super Users!

It’s the start of a new Super User season! Learn all about the new Super Users and brand-new tiered recognition system.

January 2020 Community Highlights

January 2020 Community Highlights

Make sure you didn't miss any of the things that happened in the community in January!

Difinity Conference

Difinity Conference

The largest Power BI, Power Platform, and Data conference in New Zealand

Top Solution Authors
Top Kudoed Authors