cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Johalien
Frequent Visitor

Removing any columns causes errors

Hi

 

My source data is from a google sheet. It has not changed in any way - I have been working on it for the last month.

However, suddenly I am getting errors.

 

Today I re-imported the source and noted that as soon as I remove columns I get the following error:

 

"The column of the table wasn't found"

 

It does not matter which column I remove. I will continue to get that error until I added all removed columns back.

 

Yes, I updated gateway. Yes, I checked the advanced editor. Yes, I checked the types. No, I did not add any customer columns. The ONLY thing causing this error is when I remove a column. I even made sure to make not changes except removing columns (Applied steps shows Source / Navigation / Removed Columns. Am I missing a hidden setting that I might have accidentally activated?

 

Johalien

1 ACCEPTED SOLUTION

I think I figured it out - might be related to the credentials to access the data source.

 

I cleared my cache - went to "data source settings" and cleared all permissions - then recaptured them.

 

I was able to load this source again and make all changes necessary. 

 

@Anonymous - thank you for your assistance 🙂

 

 

View solution in original post

8 REPLIES 8
Anonymous
Not applicable

@Johalien,

Sometimes when I use Excel file as a source, I would get additional null columns. To prevent this, you can use Remove Other Columns to keep the columns you want instead of removing the columns you dont need. 

Hi Nick

 

Thanks for the tip. Unfortunately I am still getting the error.

 

 

Anonymous
Not applicable

@Johalien,

Can you provide a screenshot of the error and the step before the error step? I will try my best to debug it

Steps before I get the errorSteps before I get the errorStep Causing the errorStep Causing the errorAdvanced EditorAdvanced EditorError after I apply changesError after I apply changes

Anonymous
Not applicable

@Johalien,

Did you check if your Excel file has Column1 or maybe there is an extra space after Column1 like "Column1 "? 

Hi

 

Power Bi adds two additional columns to the left. One is blank and the other is an index column. But the error is not column specific. If i remove 5 columns it will continue to give me the error until I add them all back.

 

I am getting this error when I apply any changes now and also on all my data sets looking at google sheets  Smiley Sad

 

 

I think I figured it out - might be related to the credentials to access the data source.

 

I cleared my cache - went to "data source settings" and cleared all permissions - then recaptured them.

 

I was able to load this source again and make all changes necessary. 

 

@Anonymous - thank you for your assistance 🙂

 

 

View solution in original post

Anonymous
Not applicable

I tried clearing the cache- clearing all permissions and refreshed. It doesn't seem to work. What am I missing?

Thank you!

 

 

 

ColumnError.png

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Power BI October Update 2021.jpg

Power BI Release

Click here to read more about the October 2021 Release!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Teds Dev Camp Oct. 2021 768x460.jpg

Power BI Dev Camp - October 28th, 2021

Mark your calendars and join us for our next Power BI Dev Camp!