cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Juramirez Member
Member

Relationships not working

Hi all!

 

I have two tables, one with information about workers and the other with info about bills. I need that when I select a date from slicer (Wich have dates from Bills Table) the barchart gets update but it doesn't. I must have the date from Bills Table on slicer. How can i do this? I attach a PBIX file with example of my problem (I want the bar chart next to the slicer as the one below it.)


Regards

 

1 ACCEPTED SOLUTION

Accepted Solutions
Juramirez Member
Member

Re: Relationships not working

I just solved it!

 

I've had to create a new table that only has the Dates that are in my original Database, then I relate these new Date Field  to the others Date Fields in my existing tables and it works! Just have to remember that in the new table, it must be a unique date field for each one that exists in the original tables that are in the data base.


Regards

View solution in original post

4 REPLIES 4
Vvelarde Super Contributor
Super Contributor

Re: Relationships not working

@Juramirez

 

You have only February result because: 

 

The Only UniqueIdentifier that match with UserID (Workers Table) are 4,9 and 13.

 

uid.png

 

Regards

 

Victor

Lima - Peru

 

 




Lima - Peru
Did I answer your question? Mark my post as a solution!

Proud to be a Datanaut!




pxg08680 Member
Member

Re: Relationships not working

@Juramirez

Capture.PNG

Because your join is resulting only Feb data.

 

You need to look through your data and make a join again.

Juramirez Member
Member

Re: Relationships not working

I just solved it!

 

I've had to create a new table that only has the Dates that are in my original Database, then I relate these new Date Field  to the others Date Fields in my existing tables and it works! Just have to remember that in the new table, it must be a unique date field for each one that exists in the original tables that are in the data base.


Regards

View solution in original post

ayahmed Regular Visitor
Regular Visitor

Re: Relationships not working

I have two tables with Column name "Reference number" . i am traying to create a relationship but it’s not working

any idea why

Data Type is "Text" for both

Helpful resources

Announcements
October 2019 Community Highlights

October 2019 Community Highlights

October was a busy month in the community. Read the recap article to learn about some of the events and content.

New Badges

Incoming: New and Improved Badges

Exciting news: We've given our badges an overhaul and added brand news ones.

Ask Amir Anything

Exclusive LIVE Community Event No. 2 – Ask Amir Anything

Next in our Triple A series: Ask Amir Netz questions about the latest updates, features and future.

Analytics in Azure virtual event

Analytics in Azure virtual event

Experience a limitless analytics service built to ingest, prep, manage, and serve data for immediate use in Power BI.

Users Online
Currently online: 266 members 2,578 guests
Please welcome our newest community members: