cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper I
Helper I

'Recommended provider not installed' error when trying to access Oracle DBs

I get errors when trying to access Oracle DBs.  First it says the recommended provider is not installed, then 'the provider being used is deprecated'.  I have 32+64 bit versions of the InstantClient installed, plus a full 64 bit 12.1.0.2.0 version.  All other apps/clients work perfectly.  Any suggestions as to where the disconnect is coming from please ?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Helper I
Helper I

Re: 'Recommended provider not installed' error when trying to access Oracle DBs

I have finally resolved this by installing a v12 lightweight client with ODAC - which resulted in 'Object not referenced' errors.  I then had to re-install but from the Power BI homepage, and now I can connect to Oracle without errors.

View solution in original post

4 REPLIES 4
Highlighted
Community Support
Community Support

Re: 'Recommended provider not installed' error when trying to access Oracle DBs

Hi @wattsj ,

 

Could you please try to reproduce this issue with 64-bit ODAC 12c Release 4 (12.1.0.2.4) for Windows x64 based on this document ? What the version of your Power BI Desktop?

 

9.PNG

 

Please don't have any Confidential Information or Real data in your reply.


Best regards,

 

Community Support Team _ Dong Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Helper I
Helper I

Re: 'Recommended provider not installed' error when trying to access Oracle DBs

I'm on 2.75.5649.861, 64 bit.  I've looked at installing the later version of the client, but got bogged down at where to put it and whether all the components were needed.

A colleague has the same PBI version, but only the 11.2 Oracle installs.

Highlighted
Helper I
Helper I

Re: 'Recommended provider not installed' error when trying to access Oracle DBs

I have finally resolved this by installing a v12 lightweight client with ODAC - which resulted in 'Object not referenced' errors.  I then had to re-install but from the Power BI homepage, and now I can connect to Oracle without errors.

View solution in original post

Highlighted
Community Support
Community Support

Re: 'Recommended provider not installed' error when trying to access Oracle DBs

Hi @wattsj ,


Glad to hear that you have resolved your problem. Thank you for sharing this wonderful solution, would you please kindly mark your sharing solution as an answer so that it can benefit more users?


Best regards,

Community Support Team _ Dong Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
Community Blog

Community Blog

Visit our Community Blog for articles, guides, and information created by fellow community members.

Using the Community

Using the Community

Need help with the Power BI Community? Our 'Using the Community' support articles are a great place to start.

Galleries

Galleries

Looking for inspiration on how to present your data? Need instructional videos? Check out our Galleries!

Community Summit North America

Community Summit North America

Innovate, Collaborate, Grow. The top training and networking event across the globe for Microsoft Business Applications

Top Solution Authors
Top Kudoed Authors