cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
adriansuteu Regular Visitor
Regular Visitor

Random table gets SHAREPOINT REQUEST FAILED error when refreshing data

Hi.

 

I have created a quite complex Power BI report that uses only 1 type of data sources: Excel files stored in OneDrive for Business. Everything worked fine, but a few days ago I start to get this error: "Sharepoint request failed: https://path/filename.xlsx/api/contextinfo".

 

This error does not appear for 1 table or for the same tables every time. It just appears for one of the around 20 tables (excel Sheets) from within around 10 Excel files.


I also have the lattest version of Power BI and other users got the same error on this PBI file. These users have the rights to edit the Excel files in OneDrive and until now things worked fine for them too. Now, that error is all over the place.

 

In very few situations the refresh works as it is supposed to (without this error). And this seems very strange.

I have also noticed that in Power BI service (where the report was published), both the scheduled refresh and the manual refresh work fine.

 

 

Please help me.

Much appreciate it,

Adrian

 

1 REPLY 1
Community Support Team
Community Support Team

Re: Random table gets SHAREPOINT REQUEST FAILED error when refreshing data

@adriansuteu,

 

Clear permissions in data source settings and also check the Awareness.

Community Support Team _ Sam Zha
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.