cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Karolinad
Regular Visitor

REST API (web data source) Authentication Header is gone

Dear All, 

 

I usually import data from JIRA through adding an URL as  Web Data source, using Authentication HTTP header, and an API token. 

Today I have tried to set-up a now query the same way, but it seems, "Authentication header" is not available anymore. 

 

Do you know anyithing about this? Is it renamed or just completely not supported anymore? 

 

Kind Regards

Karolina

1 ACCEPTED SOLUTION

Hi @Karolinad ,

Not sure, but acutually in lastest version of power bi desktop, the "Authorization" header does not show in the option of these headers based on my test in my environment. Maybe you can try the previous version of power bi desktop to test again.

Best Regards,
Yingjie Li

If this post helps then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

17 REPLIES 17
jpt1228
Post Patron
Post Patron

So I have been researching this for weeks. I got the credential error. Here is how I was successful getting the refresh to with with my API call. For background I was able to refresh and publish on the desktop application. However, when I published to the service and wanted to refresh it threw an error about invalid credentials.

 

I used the instructions above posted by @Karolinad . As noted in the further replies you can type in AUTHORIZATION even though it does not exist. When publishing select anonymous. It is recommended not to code your key into the query put create a one note or one drive file with the text of your key and include that as a call for the connection string.

jpt1228_0-1617147844766.png

Here is where I don't understand what happened: I could type in an API call into Postman and it would work. For some reason the key I had needed to be converted into a different string of characters in the Authorization header tab. I copied and pasted the Basic KEY123123123 part above and it connected to the API and I was able to publish and refresh in the service. I'm not super techincal but finally found a solution.

v-yingjl
Community Support
Community Support

Hi @Karolinad ,

Could you please share more details about ' "Authentication header" is not available anymore' like screenshots or codes for further discussion?

Please see this post regarding How to Get Your Question Answered Quickly:
https://community.powerbi.com/t5/Community-Blog/How-to-Get-Your-Question-Answered-Quickly/ba-p/38490

Or the following case maybe simlar that you can refer:

https://community.powerbi.com/t5/Power-Query/Pull-data-from-a-REST-API-Authentication/td-p/246006

Best Regards,
Yingjie Li

If this post helps then please consider Accept it as the solution to help the other members find it more quickly.

Dear All, 

 

Sorry for the typo, I am missing "Authorization" header in Get Data>Web>Advanced screen, when I am trying to add a new query from web source.

I have try to seek similar issue online, but I did not found anything. 

Authorization header had let me use API tokens, but apparently it is not available anymore. I have attached a screenshot, what options I have. There was a major update when user interface of PowerBI desktop changed completely, can this issue is linked with the recent update? 

 

missing authorization header.PNG

 

I have the same issue. I use the Authorization to place my Bearer API key from Airtable to make reports for my execs. I didn't see a solution on this so can someone help me? 

 

Thank you. 

Hi there!

 

So apparently, you need to do the Web import "manually" by opening a blank query, going to the advanced editor,  then, you'll see :

let
Source = ""
in
Source

 

Between the "" you sould insert the command what imports from web, then add the authorization headers manually: 

 

let
Source = Json.Document(Web.Contents("insert the URL here you used to in the regular way, and add ", [Headers=[Authorization="Basic insert your token here="]])),
issues = Source[issues],
       in
       Source 

 

Kind of sad, if you don't have basic programming skills you need to suffer thorugh process, while you can miss a comma or an "" by accident, then you have to spend so much time to find a workaround. 

 

If you have a query what have been set up earlier, just go in the advanced editor, copy the whole thing, insert the new url, clear the rest of the steps (marked with #), till only the source importing remains, start a new row and close it with in Source.

 

Hope one of these will work for you, otherwise you'll really need to use an older version (what I dont think is an efficient thing for a long time but better than nothing...) .

 

Happy Weekend!

Karolina

 

 

Hi @Karolinad I have the same problem, I need to connect an api what uses 

 

Authorization: BEARER eyJhbGciOiJIUzUxMiIsInR5cCI6IkpXVCJ9.eyJleHAiOjE2NTQyNTk5ODQsInR5cGUiOiJleHRlcm5hbCIsInVzZXIiOiJnaXVzZ----

let
Source = Json.Document(Web.Contents("https://api.estadisticasbcra.com/usd", [Headers=[Authorization: BEARER "eyJhbGciOiJIUzUxMiIsInR5cCI6IkpXVCJ9.eyJleHAiOjE2NTQyNTk5ODQsInR5cGUiOiJleHRlcm5hbCIsInVzZXIiOiJnaXVzZ----"]])),
issues = Source[issues],
       in
       Source 

 

but unfurtunately it didn't work. 

Would you help me? Thanks

Hello @luchitogiuse if you posted your query with a key you should edit that post and remove the key and replace with something random or to the ID key goes here.

Hi @jpt1228 the key isn't complete.  Thanks

@Karolinad - Thank you very much!!

Thanks @Karolinad!That worked except I didn't use the comma after [issues]

 

 

 

 

Hi all. In the March release, we restricted the list of headers shown in the UI to those that we support for all auth types. In addition, some folks on the team feel that showing the Authorization header might encourage people to put credentials into their query, which is unsafe. That said, the dropdown box, in addition to allowing you to select from the list, also allows you to type an arbirary header value. So as a workaround, you can always manually enter "Authorization", even though it no longer shows up in the list.

Hello, the authorization header still does not allow automatic updating of api? I have to use accept but the people of the api recommend me use authorization but I need automatic update.

the problem of the accept is that it always gives me error of the driver's end, I have to reduce the dates of the query a lot..

could help me

Hi @alebajares. It sounds like you may be asking about a different issue? If so, please start a new thread.

 

Ehren

Hi @Karolinad ,

Not sure, but acutually in lastest version of power bi desktop, the "Authorization" header does not show in the option of these headers based on my test in my environment. Maybe you can try the previous version of power bi desktop to test again.

Best Regards,
Yingjie Li

If this post helps then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Hi Yingije!

 

Thanks for your help. I'll do so. 

 

Regards, 

Karolina

Greg_Deckler
Super User IV
Super User IV

You could check the Issues forum here:

https://community.powerbi.com/t5/Issues/idb-p/Issues

And if it is not there, then you could post it.

If you have Pro account you could try to open a support ticket. If you have a Pro account it is free. Go to https://support.powerbi.com. Scroll down and click "CREATE SUPPORT TICKET".


---------------------------------------

@ me in replies or I'll lose your thread!!!

I have a NEW book! 
DAX Cookbook from Packt
Over 120 DAX Recipes!




Did I answer your question? Mark my post as a solution!

Proud to be a Super User!




Hi

 

I could not find there ( nor in global search), thats why I have created this post. 

I don't have a pro account what should I do, to get my post released? 

 

Regards, 

Karolina

Helpful resources

Announcements
PBI_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Get Ready for Power BI Dev Camp

Microsoft named a Leader in The Forrester Wave

Microsoft received the highest score of any vendor in both the strategy and current offering categories.

Get Ready for Power BI Dev Camp

Power BI Dev Camp - September 30th, 2021

Mark your calendars and join us for our next Power BI Dev Camp!

PowerPlatform 768x460.png

Microsoft Learn

Check out our new Discover Your Career Path blog post series and get all the details.

Top Solution Authors